Bug 1269143 - [rhelah 7.1.5] rpm-ostree ignores shell environment variable for https_proxy
[rhelah 7.1.5] rpm-ostree ignores shell environment variable for https_proxy
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpm-ostree-client (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Colin Walters
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 08:49 EDT by Ladislav Jozsa
Modified: 2016-09-14 10:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-14 10:10:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ladislav Jozsa 2015-10-06 08:49:32 EDT
Description of problem:
rpm-ostree does not honor https_proxy env variable value. https requests aren't sent to https proxy when this variable is set.

When I set http_proxy env variable, https requests are directed to $http_proxy value.

The behavior can be tested by running 'rpm-ostree upgrade'.

I cannot report the rpm-ostree version due to bz#1269140
Comment 1 Micah Abbott 2015-10-06 10:03:14 EDT
Using 'rpm -qi rpm-ostree-client' on 7.1.5:

# rpm -qi rpm-ostree-client
Name        : rpm-ostree-client
Version     : 2015.5
Release     : 4.atomic.el7
Architecture: x86_64
Install Date: Fri 11 Sep 2015 06:27:09 PM UTC
Group       : Unspecified
Size        : 215992
License     : LGPLv2+
Signature   : (none)
Source RPM  : rpm-ostree-client-2015.5-4.atomic.el7.src.rpm
Build Date  : Wed 10 Jun 2015 04:29:48 PM UTC
Build Host  : x86-017.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : https://github.com/projectatomic/rpm-ostree
Summary     : Client side upgrade program
Description :
This tool binds together the world of RPM packages with
the OSTree model of bootable filesystem trees.  It provides commands
usable on client systems to upgrade and rollback.
Comment 3 Colin Walters 2016-09-14 10:10:50 EDT
See this upstream issue: https://github.com/projectatomic/rpm-ostree/issues/208

Note You need to log in before you can comment on or make changes to this bug.