Bug 1269177 - [Docs] [Director] Overcloud satellite 6 registration during deployment doesn't work when using reg-sat-url using https
[Docs] [Director] Overcloud satellite 6 registration during deployment doesn'...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
All Linux
urgent Severity urgent
: y1
: 7.0 (Kilo)
Assigned To: Dan Macpherson
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 10:12 EDT by Anand Nande
Modified: 2015-10-12 00:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 00:19:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anand Nande 2015-10-06 10:12:09 EDT
Description of problem:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html-single/Director_Installation_and_Usage/index.html#appe-Deployment_Parameters

states just 

--reg-sat-url [REG_SAT_URL] Satellite 6 server to register Overcloud nodes


Due to this, the deployment does not succeed :

But the overcloud nodes were not registered with the satellite server.

Need to specifically use :

--reg-sat-url http://satellite-url

in this case, 'https' wont work.
Comment 2 Anand Nande 2015-10-06 10:13:39 EDT
explicitly mention 'http' in the documentation.
Comment 4 Andrew Dahms 2015-10-07 17:32:53 EDT
Updated flags.
Comment 5 Dan Macpherson 2015-10-07 21:51:37 EDT
This is now live:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/appe-Deployment_Parameters.html

Description for --reg-sat-url says:

Satellite 6 server to register Overcloud nodes. Use the Satellite's HTTP URL and not the HTTPS URL for this parameter. For example, use http://satellite.example.com and not https://satellite.example.com. 

Anand -- Does this suit the requirements of this bug?
Comment 6 Anand Nande 2015-10-08 02:21:10 EDT
Dan - Perfect! Thanks a ton.

Note You need to log in before you can comment on or make changes to this bug.