Bug 1269202 - More typos in Director Install and Config guide.
More typos in Director Install and Config guide.
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
All All
unspecified Severity low
: ---
: 8.0 (Liberty)
Assigned To: RHOS Documentation Team
RHOS Documentation Team
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 11:38 EDT by Dan Yocum
Modified: 2015-10-07 12:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-06 21:48:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Yocum 2015-10-06 11:38:07 EDT
In section 6.3.8, the network-isolation.yaml file is first mentioned in the command to deploy the overcloud w/o defining this file elsewhere. 

I suspect that the immediately preceding section, which is called "6.3.7.3. Assigning OpenStack Services to Isolated Networks," should refer to this file instead of network-environment.yaml.
Comment 2 Dan Macpherson 2015-10-06 21:48:41 EDT
This is not a bug. The network-isolation file is located in /usr/share/openstack-tripleo-heat-templates/environments/ and is a part of the openstack-tripleo-heat-templates package. You do not create this file.

Below the command, there is a description for this file:

-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml - The -e option adds an additional environment file to the Overcloud plan. In this case, it is an environment file that initializes network isolation configuration.

You also need the network-environment.yaml, which you define in Section 6.3.7.3, because this configures your specific interfaces. There is a description for this file below the deployment command:

-e /home/stack/templates/network-environment.yaml - The -e option adds an additional environment file to the Overcloud plan. In this case, it is the network environment file we created from Section 6.2.5.2, “Creating a Basic Overcloud Network Environment Template”. 

Both files are needed for deployment.

Closing this bug as NOTABUG
Comment 3 Dan Yocum 2015-10-07 12:29:54 EDT
Ok - but, you see the source of my confusion, right?   It's the name of the section: "6.3.7.3. Assigning OpenStack Services to Isolated Networks"

How about changing the title to: "6.3.7.3. Assigning OpenStack Services to Individual Networks"  or "6.3.7.3. Assigning OpenStack Services to Separated Networks" ?

Thanks!

Note You need to log in before you can comment on or make changes to this bug.