Bug 1269215 - ifup brings up IPoIB interface wrongly (following initscripts update?)
ifup brings up IPoIB interface wrongly (following initscripts update?)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Lukáš Nykrýn
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 12:47 EDT by Dave Love
Modified: 2016-11-25 08:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 07:49:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Love 2015-10-06 12:47:32 EDT
Description of problem:

An IPoIB interface which was correctly configured previously has come up in a bad state after a recent reboot, presumably following an initscripts update since the last boot.
It's supposed to be operating in CONNECTED_MODE (set in ifcfg-ib0) but actually came up in datagram mode, with resulting grief on the NFS mounts.
It turns out that ifup brings it up using ifup-eth, not ifup-ib because there's no keys-ib0 file which it checks for.
I don't know where that's supposed to come from, and unfortunately don't have a backup to know if it was there previously when the interface came up correctly.  Creating one with the right contents fixed the problem.

Version-Release number of selected component (if applicable):
initscripts-9.03.49-1.el6_7.1.x86_64
Comment 2 Orion Poplawski 2015-10-06 13:59:25 EDT
Working fine for me because I have:

TYPE=InfiniBand

in my ifcfg-ib0 file which is what sets the DEVICETYPE used for ifup-$DEVICETYPE.  It should also work if TYPE is missing, because then it should strip the number from DEVICE and use that.
Comment 3 Lukáš Nykrýn 2015-10-07 03:13:03 EDT
DO you have the original ifcfg file?
Comment 4 Dave Love 2015-10-07 06:27:54 EDT
(In reply to Orion Poplawski from comment #2)
> Working fine for me because I have:
> 
> TYPE=InfiniBand
> 
> in my ifcfg-ib0 file which is what sets the DEVICETYPE used for
> ifup-$DEVICETYPE.  It should also work if TYPE is missing, because then it
> should strip the number from DEVICE and use that.

Thanks for the clue.  TYPE is undocumented as far as I can see, but it turns
out our dear vendor had set it to Ethernet originally.  I should have looked
more closely -- sorry for the noise.  It works once I remove that.

Something seems to have changed in initscripts because it was originally working
somehow, but the change looks like a bug fix if anything.  (I realized since
it's under etckeeper I could check the whole configuration was unchanged.)

I don't seem to have a way to mark this as invalid.

Note You need to log in before you can comment on or make changes to this bug.