Bug 1269221 - SR-IOV on Cisco UCS environment reports "error: unsupported configuration: Interface type hostdev is currently supported on SR-IOV Virtual Functions only" when attempting to start VM with SR-IOV
SR-IOV on Cisco UCS environment reports "error: unsupported configuration: In...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.1
All Linux
high Severity high
: rc
: ---
Assigned To: Pavel Hrdina
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-06 13:13 EDT by Allan Voss
Modified: 2016-05-29 16:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 07:18:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allan Voss 2015-10-06 13:13:41 EDT
Description of problem:
SR-IOV on Cisco UCS environment reports "error: unsupported configuration: Interface type hostdev is currently supported on SR-IOV Virtual Functions only" when attempting to start VM with SR-IOV

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 7.1 (Maipo)

How reproducible:
Unknown

Steps to Reproduce:
1. Configure Cisco according to documentation: http://www.cisco.com/c/en/us/td/docs/unified_computing/ucs/sw/vm_fex/kvm/cli/config_guide/2-1/b_CLI_KVM_VM-FEX_UCSM_Configuration_Guide_2_1/b_CLI_KVM_VM-FEX_UCSM_Configuration_Guide_2_1_chapter_010.html
2. Follow documentation at https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Virtualization_Deployment_and_Administration_Guide/sect-SR_IOV-Using_SR_IOV.html to configure SR-IOV
3. Start the VM

Actual results:
# virsh start test-VM
error: Failed to start domain test-VM
error: unsupported configuration: Interface type hostdev is currently supported on SR-IOV Virtual Functions only

Expected results:
Successful VM start

Additional info:
Comment 3 Pavel Hrdina 2015-10-09 09:28:14 EDT
Hi, I was investigating this issue and it seems, that you've miss-configured the Cisco VIC.  According the sosreport, the eth1-eth4 are "Dynamic Virtual Adapters" cards, not a Virtual Function.  In general, there should be only one physical network card assigned to the host, the card must have enabled Virtual Function and the virtual cards, that are used for SR-IOV hase to by enabled according the Red Hat Deployment Guide by executing:

   "echo {number} > /sys/class/net/{network}/device/sriov_numvfs"

   where {number} is a requested count of Virtual Function cards
   and {network} is the name of network card, so for example:

   "echo 2 > /sys/class/net/eth0/device/sriov_numvfs"

Please review your Cisco VIC settings and also if it's possible to enable the Virtual Function for the network card.
Comment 4 Pavel Hrdina 2015-11-09 06:09:53 EST
It's been a month without any reaction, is this bug resolved?
Comment 5 hongming 2015-11-11 00:56:09 EST
Hi Allan 

I have verified the following bug using libvirt-1.2.17-8.el7.x86_64. It works fine.The result is expected. Please refer to the configuration in the bug.

https://bugzilla.redhat.com/show_bug.cgi?id=1257004#c7
Comment 6 hongming 2015-11-12 04:33:11 EST
Also test SRIOV VF passthrough , The result is expected.

[root@cisco-b230m2-1 ~]# rpm -q libvirt
libvirt-1.2.17-13.el7.x86_64


[root@cisco-b230m2-1 ~]# lspci|grep Eth
06:00.0 Ethernet controller: Cisco Systems Inc VIC Ethernet NIC (rev a2)
06:00.1 Ethernet controller: Cisco Systems Inc VIC SR-IOV VF (rev a2)
06:00.2 Ethernet controller: Cisco Systems Inc VIC SR-IOV VF (rev a2)


[root@cisco-b230m2-1 ~]# virsh nodedev-list --tree
computer
  |
  +- net_lo_00_00_00_00_00_00
  +- net_virbr0_nic_52_54_00_46_be_b8
  +- pci_0000_00_00_0
  +- pci_0000_00_01_0
  +- pci_0000_00_03_0
  |   |
  |   +- pci_0000_02_00_0
  |       |
  |       +- pci_0000_03_00_0
  |           |
  |           +- pci_0000_04_00_0
  |               |
  |               +- pci_0000_05_00_0
  |               |   |
  |               |   +- pci_0000_06_00_0
  |               |   |   |
  |               |   |   +- net_enp6s0f0_00_25_b5_00_00_00
  |               |   |     
  |               |   +- pci_0000_06_00_1
  |               |   |   |
  |               |   |   +- net_enp6s0f1_00_00_00_00_00_00
  |               |   |     
  |               |   +- pci_0000_06_00_2
  |               |       |
  |               |       +- net_enp6s0f2_00_00_00_00_00_00
  |               |         


[root@cisco-b230m2-1 ~]# virsh start r7.1
Domain r7.1 started

[root@cisco-b230m2-1 ~]# virsh dumpxml r7.1|grep /interface -B11
    </controller>
    <interface type='direct'>
      <mac address='52:54:00:d5:37:6a'/>
      <source dev='enp6s0f2' mode='passthrough'/>
      <virtualport type='802.1Qbh'>
        <parameters profileid='hm-test'/>
      </virtualport>
      <target dev='macvtap0'/>
      <model type='virtio'/>
      <alias name='net0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    </interface>
    <interface type='hostdev' managed='yes'>
      <mac address='52:54:00:d5:af:6d'/>
      <driver name='vfio'/>
      <source>
        <address type='pci' domain='0x0000' bus='0x06' slot='0x00' function='0x1'/>
      </source>
      <virtualport type='802.1Qbh'>
        <parameters profileid='hm-test'/>
      </virtualport>
      <alias name='hostdev0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x08' function='0x0'/>
    </interface>
Comment 7 Pavel Hrdina 2015-12-02 07:18:10 EST
Since there was no reaction from customer and according to Hongming this works as expected and there is no issue from our side I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.