Bug 126929 - HP DL 380 G3 randomly freezes
HP DL 380 G3 randomly freezes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-29 06:36 EDT by Jørgen Nørgaard
Modified: 2015-01-04 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 02:16:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jørgen Nørgaard 2004-06-29 06:36:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.2 (KHTML, like Gecko) Safari/125.8

Description of problem:
On a HP DL 380 G3 with all up2date updates (as of today) we experience occasional freezes.

The system runs for 1 day or longer up to appr. 10 days and then suddenly freezes. In this state X11 (xdm) does not respond any longer.

The network responds to ping, but not to traffic such as ssh.


There is nothing in the log files (boot.log, messages) that indicates what might be the problem.

At this time I don't have any further information to go on.





Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
run the system for a number of days

Additional info:
Comment 1 Jørgen Nørgaard 2004-06-29 06:37:59 EDT
dmesg output:

Linux version 2.6.5-1.358 (bhcompile@bugs.build.redhat.com) (gcc version 
3.3.3 20040412 (Red Hat Linux 3.3.3-7)) #1 Sat May 8 09:04:50 EDT 2004
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009f400 (usable)
 BIOS-e820: 000000000009f400 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000007fffa000 (usable)
 BIOS-e820: 000000007fffa000 - 0000000080000000 (ACPI data)
 BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fee10000 (reserved)
 BIOS-e820: 00000000ffc00000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
2047MB LOWMEM available.
zapping low mappings.
On node 0 totalpages: 524282
  DMA zone: 4096 pages, LIFO batch:1
  Normal zone: 520186 pages, LIFO batch:16
  HighMem zone: 0 pages, LIFO batch:1
DMI 2.3 present.
ACPI: RSDP (v000 COMPAQ                                    ) @ 0x000f4f70
ACPI: RSDT (v001 COMPAQ P29      0x00000002 “ 0x0000162e) @ 0x7fffa000
ACPI: FADT (v001 COMPAQ P29      0x00000002 “ 0x0000162e) @ 0x7fffa040
ACPI: MADT (v001 COMPAQ 00000083 0x00000002  0x00000000) @ 0x7fffa100
ACPI: SPCR (v001 COMPAQ SPCRRBSU 0x00000001 “ 0x0000162e) @ 0x7fffa1c0
ACPI: DSDT (v001 COMPAQ     DSDT 0x00000001 MSFT 0x0100000b) @ 0x00000000
ACPI: PM-Timer IO Port: 0x920
Built 1 zonelists
Kernel command line: ro root=LABEL=/ rhgb quiet
mapped 4G/4G trampoline to ffff3000.
Initializing CPU#0
CPU 0 irqstacks, hard=02345000 soft=02344000
PID hash table entries: 4096 (order 12: 32768 bytes)
Detected 3057.551 MHz processor.
Using pmtmr for high-res timesource
Console: colour VGA+ 80x25
Memory: 2076900k/2097128k available (1540k kernel code, 19488k reserved, 599k data, 
144k init, 0k highmem)
Calibrating delay loop... 6062.08 BogoMIPS
Security Scaffold v1.0.0 initialized
SELinux:  Initializing.
SELinux:  Starting in permissive mode
There is already a security framework initialized, register_security failed.
Failure registering capabilities with the kernel
selinux_register_security:  Registering secondary module capability
Capability LSM initialized
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU:     After generic identify, caps: bfebf9ff 00000000 00000000 00000000
CPU:     After vendor identify, caps: bfebf9ff 00000000 00000000 00000000
CPU: Trace cache: 12K uops, L1 D cache: 8K
CPU: L2 cache: 512K
CPU:     After all inits, caps: bfebf1ff 00000000 00000000 00000080
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU#0: Intel P4/Xeon Extended MCE MSRs (12) available
CPU: Intel(R) Xeon(TM) CPU 3.06GHz stepping 09
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xf0094, last bus=9
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20040326
ACPI: IRQ9 SCI: Level Trigger.
    ACPI-1059: *** Info: There are no GPE blocks defined in the FADT
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
PCI: Ignoring BAR0-3 of IDE controller 0000:00:0f.1
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Root Bridge [PCI1] (00:01)
PCI: Probing PCI hardware (bus 01)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI1._PRT]
ACPI: PCI Root Bridge [PCI2] (00:02)
PCI: Probing PCI hardware (bus 02)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI2._PRT]
ACPI: PCI Root Bridge [PCI3] (00:03)
PCI: Probing PCI hardware (bus 03)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI3._PRT]
ACPI: PCI Root Bridge [PCI4] (00:06)
PCI: Probing PCI hardware (bus 06)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI4._PRT]
ACPI: PCI Interrupt Link [IUSB] (IRQs 4 5 *7 10 11 15)
ACPI: PCI Interrupt Link [IN16] (IRQs 4 5 7 10 11 15)
ACPI: PCI Interrupt Link [IN17] (IRQs 4 *5 7 10 11 15)
ACPI: PCI Interrupt Link [IN18] (IRQs 4 5 7 10 11 *15)
ACPI: PCI Interrupt Link [IN19] (IRQs 4 5 7 10 11 15)
ACPI: PCI Interrupt Link [IN20] (IRQs 4 5 7 10 11 15)
ACPI: PCI Interrupt Link [IN21] (IRQs 4 5 7 10 11 15)
ACPI: PCI Interrupt Link [IN22] (IRQs 4 5 7 10 11 15)
ACPI: PCI Interrupt Link [IN23] (IRQs 4 5 7 10 11 15)
ACPI: PCI Interrupt Link [IN24] (IRQs 4 5 7 10 11 15)
ACPI: PCI Interrupt Link [IN25] (IRQs 4 5 7 10 11 15)
ACPI: PCI Interrupt Link [IN26] (IRQs 4 5 7 10 11 15)
ACPI: PCI Interrupt Link [IN27] (IRQs 4 5 7 10 11 15)
ACPI: PCI Interrupt Link [IN28] (IRQs 4 5 7 10 11 15)
ACPI: PCI Interrupt Link [IN29] (IRQs 4 5 7 10 *11 15)
ACPI: PCI Interrupt Link [IN30] (IRQs 4 5 7 *10 11 15)
ACPI: PCI Interrupt Link [IN31] (IRQs 4 5 7 10 11 *15)
ACPI: PCI Interrupt Link [IN32] (IRQs 4 5 7 10 11 15)
ACPI: PCI Interrupt Link [IN33] (IRQs 4 5 7 10 11 15)
ACPI: PCI Interrupt Link [IN34] (IRQs 4 5 7 10 11 15)
Linux Plug and Play Support v0.97 (c) Adam Belay
usbcore: registered new driver usbfs
usbcore: registered new driver hub
ACPI: PCI Interrupt Link [IN16] enabled at IRQ 3
ACPI: PCI Interrupt Link [IN17] enabled at IRQ 5
ACPI: PCI Interrupt Link [IUSB] enabled at IRQ 7
ACPI: PCI Interrupt Link [IN30] enabled at IRQ 10
ACPI: PCI Interrupt Link [IN29] enabled at IRQ 11
ACPI: PCI Interrupt Link [IN31] enabled at IRQ 15
ACPI: PCI Interrupt Link [IN18] enabled at IRQ 15
PCI: Using ACPI for IRQ routing
PCI: if you experience problems, try using option 'pci=noacpi' or even 'acpi=off'
PCI: Device 00:00 not found by BIOS
PCI: Device 00:01 not found by BIOS
PCI: Device 00:02 not found by BIOS
PCI: Device 00:78 not found by BIOS
PCI: Device 00:7b not found by BIOS
PCI: Device 00:80 not found by BIOS
PCI: Device 00:82 not found by BIOS
PCI: Device 00:88 not found by BIOS
PCI: Device 00:8a not found by BIOS
apm: BIOS not found.
audit: initializing netlink socket (disabled)
audit(1088498170.008:0): initialized
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
SELinux:  Registering netfilter hooks
Initializing Cryptographic API
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
ACPI: Processor [CPU0] (supports C1)
ACPI: Thermal Zone [THM0] (8 C)
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Unsupported Serverworks chipset (device id: 0014)
agpgart: Unsupported Serverworks chipset (device id: 0014)
agpgart: Unsupported Serverworks chipset (device id: 0014)
agpgart: Unsupported Serverworks chipset (device id: 0225)
agpgart: Unsupported Serverworks chipset (device id: 0101)
agpgart: Unsupported Serverworks chipset (device id: 0101)
agpgart: Unsupported Serverworks chipset (device id: 0101)
agpgart: Unsupported Serverworks chipset (device id: 0101)
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing enabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
divert: not allocating divert_blk for non-ethernet device lo
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
SvrWks CSB5: IDE controller at PCI slot 0000:00:0f.1
SvrWks CSB5: chipset revision 147
SvrWks CSB5: not 100% native mode: will probe irqs later
SvrWks CSB5: simplex device: DMA forced
    ide0: BM-DMA at 0x2000-0x2007, BIOS settings: hda:pio, hdb:pio
SvrWks CSB5: simplex device: DMA forced
    ide1: BM-DMA at 0x2008-0x200f, BIOS settings: hdc:pio, hdd:pio
hda: COMPAQ CD-ROM SN-124, ATAPI CD/DVD-ROM drive
Using cfq io scheduler
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: ATAPI 24X CD-ROM drive, 128kB Cache
Uniform CD-ROM driver Revision: 3.20
ide-floppy driver 0.99.newide
usbcore: registered new driver hiddev
usbcore: registered new driver hid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
mice: PS/2 mouse device common for all mice
serio: i8042 AUX port at 0x60,0x64 irq 12
input: PS/2 Logitech Mouse on isa0060/serio1
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
NET: Registered protocol family 2
IP: routing cache hash table of 16384 buckets, 128Kbytes
TCP: Hash tables configured (established 524288 bind 65536)
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
ACPI: (supports S0 S4 S5)
checking if image is initramfs...it isn't (no cpio magic); looks like an initrd
Freeing initrd memory: 256k freed
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem).
SCSI subsystem initialized
Compaq CISS Driver (v 2.6.0)
cciss: Device 0xb178 has been found at bus 1 dev 3 func 0
cciss: using DAC cycles
      blocks= 71122560 block_size= 512
      heads= 255, sectors= 32, cylinders= 8716

 cciss/c0d0: p1 p2 p3
EXT3-fs: INFO: recovery required on readonly filesystem.
EXT3-fs: write access will be enabled during recovery.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: cciss/c0d0p2: orphan cleanup on readonly fs
ext3_orphan_cleanup: deleting unreferenced inode 336859
ext3_orphan_cleanup: deleting unreferenced inode 3981412
ext3_orphan_cleanup: deleting unreferenced inode 950282
ext3_orphan_cleanup: deleting unreferenced inode 335701
ext3_orphan_cleanup: deleting unreferenced inode 341407
ext3_orphan_cleanup: deleting unreferenced inode 337315
ext3_orphan_cleanup: deleting unreferenced inode 35773
ext3_orphan_cleanup: deleting unreferenced inode 35772
ext3_orphan_cleanup: deleting unreferenced inode 341511
ext3_orphan_cleanup: deleting unreferenced inode 337821
ext3_orphan_cleanup: deleting unreferenced inode 341512
ext3_orphan_cleanup: deleting unreferenced inode 950615
ext3_orphan_cleanup: deleting unreferenced inode 950317
EXT3-fs: cciss/c0d0p2: 13 orphan inodes deleted
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
Freeing unused kernel memory: 144k freed
SELinux:  Disabled at runtime.
SELinux:  Unregistering netfilter hooks
NET: Registered protocol family 10
Disabled Privacy Extensions on device 022db720(lo)
IPv6 over IPv4 tunneling driver
divert: not allocating divert_blk for non-ethernet device sit0
ACPI: Power Button (FF) [PWRF]
ohci_hcd: 2004 Feb 02 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ohci_hcd: block sizes: ed 64 td 64
ohci_hcd 0000:00:0f.2: OHCI Host Controller
ohci_hcd 0000:00:0f.2: irq 7, pci mem 82851000
ohci_hcd 0000:00:0f.2: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 4 ports detected
EXT3 FS on cciss/c0d0p2, internal journal
device-mapper: 4.1.0-ioctl (2003-12-10) initialised: dm@uk.sistina.com
cdrom: open failed.
Adding 2044072k swap on /dev/cciss/c0d0p3.  Priority:-1 extents:1
kjournald starting.  Commit interval 5 seconds
EXT3 FS on cciss/c0d0p1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
IA-32 Microcode Update Driver: v1.13 <tigran@veritas.com>
microcode: No suitable data for cpu 0
inserting floppy driver for 2.6.5-1.358
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
tg3.c:v3.3 (April 27, 2004)
divert: allocating divert_blk for eth0
eth0: Tigon3 [partno(NA) rev 1002 PHY(5703)] (PCIX:100MHz:64-bit) 10/100/1000BaseT 
Ethernet 00:0f:20:6b:64:57
eth0: HostTXDS[0] RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] Split[0] WireSpeed[1] 
TSOcap[1] 
divert: allocating divert_blk for eth1
eth1: Tigon3 [partno(NA) rev 1002 PHY(5703)] (PCIX:100MHz:64-bit) 10/100/1000BaseT 
Ethernet 00:0f:20:6b:64:56
eth1: HostTXDS[0] RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] Split[0] WireSpeed[1] 
TSOcap[1] 
divert: freeing divert_blk for eth0
divert: freeing divert_blk for eth1
ip_tables: (C) 2000-2002 Netfilter core team
tg3.c:v3.3 (April 27, 2004)
divert: allocating divert_blk for eth0
eth0: Tigon3 [partno(NA) rev 1002 PHY(5703)] (PCIX:100MHz:64-bit) 10/100/1000BaseT 
Ethernet 00:0f:20:6b:64:57
eth0: HostTXDS[0] RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] Split[0] WireSpeed[1] 
TSOcap[1] 
divert: allocating divert_blk for eth1
eth1: Tigon3 [partno(NA) rev 1002 PHY(5703)] (PCIX:100MHz:64-bit) 10/100/1000BaseT 
Ethernet 00:0f:20:6b:64:56
eth1: HostTXDS[0] RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] Split[0] WireSpeed[1] 
TSOcap[1] 
ip_tables: (C) 2000-2002 Netfilter core team
tg3: eth0: Link is up at 100 Mbps, full duplex.
tg3: eth0: Flow control is off for TX and off for RX.
ip_tables: (C) 2000-2002 Netfilter core team
eth0: no IPv6 routers present
tg3: eth1: Link is up at 100 Mbps, full duplex.
tg3: eth1: Flow control is off for TX and off for RX.
eth1: no IPv6 routers present
mtrr: no more MTRRs available
mtrr: no more MTRRs available
Comment 2 Dave Jones 2005-01-14 00:30:56 EST
any better with the latest 2.6.10 updates ?
Comment 3 Jørgen Nørgaard 2005-01-14 02:16:37 EST
With FC 2 and recently FC3 (now updated to 2.6.10) I haven't seen this for a long time now.


It may actually have been resolved by a couple of firmware updates from HP and a Fedora problem after 
all.


Note You need to log in before you can comment on or make changes to this bug.