Bug 126930 - large files break directory listing
large files break directory listing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-29 08:02 EDT by NC
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 2.0.50-2.1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-20 05:13:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description NC 2004-06-29 08:02:16 EDT
Description of problem:

apache is not compiled for large files, which means that it shows 
incorrect sizes with large files or doesn't show directory output. 

Version-Release number of selected component (if applicable):

httpd-2.0.40-21.11

How reproducible:

create/copy a large file, into a directory on your www-server, view 
filesize in the directory listing... 

Steps to Reproduce:
1. copy large file ( for example dvd-image ) into directory
2. open browser, view directory 
3.
  
Actual results:

Index of /mirror/redhat-linux/fedora/linux/core/2/i386/iso

 Name                                           Last modified      
Size  Description

 Parent Directory                                                    
-   
 FC2-i386-SRPMS-disc1.iso                       13-May-2004 11:48  
498M  
Apache/2.0.40 Server at ftp.tugraz.at Port 80

Expected results:

drwxr-xr-x    2 zuzl     ftpadmin     4096 May 14 20:35 .
drwxr-xr-x    5 zuzl     ftpadmin     4096 May 14 13:33 ..
-rw-r--r--    1 zuzl     ftpadmin 4370640896 May 13 12:02 
FC2-i386-DVD.iso
-rw-r--r--    1 zuzl     ftpadmin 521977856 May 13 11:48 
FC2-i386-SRPMS-disc1.iso
-rw-r--r--    1 zuzl     ftpadmin 521996288 May 13 11:49 
FC2-i386-SRPMS-disc2.iso
-rw-r--r--    1 zuzl     ftpadmin 521975808 May 13 11:51 
FC2-i386-SRPMS-disc3.iso
-rw-r--r--    1 zuzl     ftpadmin 522008576 May 13 11:52 
FC2-i386-SRPMS-disc4.iso
-rw-r--r--    1 zuzl     ftpadmin 667529216 May 13 11:41 
FC2-i386-disc1.iso
-rw-r--r--    1 zuzl     ftpadmin 665802752 May 13 11:43 
FC2-i386-disc2.iso
-rw-r--r--    1 zuzl     ftpadmin 669016064 May 13 11:45 
FC2-i386-disc3.iso
-rw-r--r--    1 zuzl     ftpadmin 203737088 May 13 11:46 
FC2-i386-disc4.iso
-rw-r--r--    1 zuzl     ftpadmin 79532032 May 13 11:38 
FC2-i386-rescuecd.iso
-rw-r--r--    1 zuzl     ftpadmin      791 May 13 21:25 MD5SUM


Additional info:

tested on mozilla 1.6, opera for windows Version	7.23, IE 6
Comment 1 Joe Orton 2004-06-29 11:36:34 EDT
httpd-2.0.40-21.11 is the RHL9 package, not the FC2 package.

This is a known bug, the fix to not truncate the autoindex listing for
a >2Gb file will be integrated for the next FC2 update.

On x86, httpd will not be able to serve >2Gb files however, and they
will be omitted from the autoindex listing.
Comment 2 Joe Orton 2004-07-20 05:13:29 EDT
This is fixed in the 2.0.50-2.1 update.
Comment 3 Gregory Maxwell 2004-08-11 10:38:48 EDT
So.. Lack of support for files >2gb (not just listing) is a really
weak limitation.. We got largefile support when? and >2gb files are
*still* treated as second class citizens... Updating the complete
system to handle large files it the sort of thing distros should be doing.

Should I go ahead and create a second bug for lack of largefile
support in apache?
Comment 4 Joe Orton 2004-08-11 10:48:34 EDT
There's no need, we have already implemented largefile support
upstream for Apache 2.2.  Unfortunately, it can't be added in a 2.0.x
release because it changes the binary module interface; that's also
the reason why it's not OK for us to patch it in.

Note You need to log in before you can comment on or make changes to this bug.