Bug 1269390 - fs/nfsd/nfs4state.c:3937 nfsd4_process, and lib/list_debug.c:53 __list_del_entry+0x70/0xe0
fs/nfsd/nfs4state.c:3937 nfsd4_process, and lib/list_debug.c:53 __list_del_en...
Status: CLOSED DUPLICATE of bug 1236688
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: nfs-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 03:53 EDT by Edgar Hoch
Modified: 2015-10-20 16 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-14 11:40:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Extract form journalctl long time before the crash there is a kernel bug at fs/nfsd/nfs4state.c:3937 nfsd4_process_open (4.46 KB, text/plain)
2015-10-07 03:53 EDT, Edgar Hoch
no flags Details
Extract form journalctl long time before the crash there are strange messeges about rpc-srv/tcp: nfsd (244 bytes, text/plain)
2015-10-07 03:56 EDT, Edgar Hoch
no flags Details
Extract form journalctl long time before the crash there are strange messeges about perf (475 bytes, text/plain)
2015-10-07 03:56 EDT, Edgar Hoch
no flags Details
Extract form journalctl just before the crash with kernel bug at lib/list_debug.c:53 __list_del_entry (15.37 KB, text/plain)
2015-10-07 03:58 EDT, Edgar Hoch
no flags Details
kernel trace of fs/nfsd/nfs4state.c:3956 nfsd4_process_open2 (3.90 KB, text/plain)
2015-10-20 16:01 EDT, Edgar Hoch
no flags Details

  None (edit)
Description Edgar Hoch 2015-10-07 03:53:36 EDT
Created attachment 1080538 [details]
Extract form journalctl long time before the crash there is a kernel bug at fs/nfsd/nfs4state.c:3937 nfsd4_process_open

Description of problem:

Our file server crashes / freezes suddenly since about some weeks. It happens with Fedora 21, with a 4.x kernel, and with Fedora 22 (I have installed it a Sep 27, 2015).

The server crashes sometimes after some hours again, sometimes not until some days.

The crash seems always have to do with the kernel module nfsd, I append serveral files with extracts from journalctl from the same boot (between a reboot and the following crash). There are serveral error messages - after the last in the list the system was crashed (frozen).


Please could you help us to fix the problem? Is there a kernel which has fixed the problem? Is this problem already known or new?



Version-Release number of selected component (if applicable):
kernel-4.1.8-200.fc22.x86_64
nfs-utils-1.3.2-9.fc22.x86_64
nfs4-acl-tools-0.3.3-15.fc22.x86_64


How reproducible:
non-deterministic, the machine freezes after a random time.

Steps to Reproduce:
1. Start a Fedora 22 system with nfs export of ext4 files systems with facl and quota enabled (for home directories of users).
2. Use nfs clients that mounts and uses this nfs server.
3. Wait until the server crashes (random time) - I don't know what triggers the crash.
Comment 1 Edgar Hoch 2015-10-07 03:56 EDT
Created attachment 1080539 [details]
Extract form journalctl long time before the crash there are strange messeges about rpc-srv/tcp: nfsd
Comment 2 Edgar Hoch 2015-10-07 03:56 EDT
Created attachment 1080540 [details]
Extract form journalctl long time before the crash there are strange messeges about perf
Comment 3 Edgar Hoch 2015-10-07 03:58 EDT
Created attachment 1080541 [details]
Extract form journalctl just before the crash with kernel bug at lib/list_debug.c:53 __list_del_entry
Comment 4 J. Bruce Fields 2015-10-14 11:40:16 EDT
rpc and perf messages look unrelated, list_debug warnings are probably the real cause.  This looks like a dup of bug 1236688, could you confirm after update to 4.1.10?

*** This bug has been marked as a duplicate of bug 1236688 ***
Comment 5 Edgar Hoch 2015-10-15 13:09:20 EDT
Our server crashed again today (after 8 days without crash), but with kernel 4.1.8. It has the same error messages as reported here.

Now, after reboot, the server runs with kernel 4.1.10.
I don't know how I can cause the server to run into this bug. I can just wait and tell you after some days if the server has crashed again or not.

I will possibly try the "Steps to Reproduce" of bug #1236688 to test if I can reproduce the bug on another system with the new and an older kernel.
Comment 6 Edgar Hoch 2015-10-20 16:01 EDT
Created attachment 1084919 [details]
kernel trace of fs/nfsd/nfs4state.c:3956 nfsd4_process_open2

My server is still running with kernel 4.1.10-200.fc22.x86_64 without a crash (since 16th October 2015). But I found a warning (see attachment).

I will make a new comment if the server will crash again with the error described in this bug report.

Thanks for your comments and patches!

Note You need to log in before you can comment on or make changes to this bug.