Bug 1269393 - [SR-IOV] - Block moving and importing VMs with 'pci-passthrough' vNIC types and profiles to clusters <3.6
[SR-IOV] - Block moving and importing VMs with 'pci-passthrough' vNIC types a...
Status: CLOSED WONTFIX
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.0
x86_64 Linux
medium Severity medium (vote)
: ovirt-4.1.0-alpha
: ---
Assigned To: nobody nobody
Michael Burman
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 04:09 EDT by Michael Burman
Modified: 2016-07-20 05:57 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-20 05:57:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.1?
ylavi: planning_ack-
mburman: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Michael Burman 2015-10-07 04:09:19 EDT
Description of problem:
[SR-IOV] - Block moving and importing VMs with 'pci-passthrough' vNIC types and profiles to clusters  <3.6

I'm reporting this bug in order to decide if we should block moving and importing VMs with 'pci-passthrough' and profiles to clusters below 3.6.
- Should we block in UI ?
- Compatibility version- UI clusters less than 3.6 - sriov checkboxes(passthrough) should be disabled in the vNIC profile dialog and shouldn't appear in the vNICs type list(pci-passthrouhg) ? 

Version-Release number of selected component (if applicable):
3.6.0-0.18.el6
Comment 1 Michael Burman 2015-10-20 05:00:41 EDT
In current version 3.6.0.1-0.1.el6 in clusters 3.5, 'passthrough' checkbox appears in vNIC profile dialog and 'pci-passthrough' type is part of the type list in vNIC's dialog. This should be disabled or shouldn't be exist at all for clusters below 3.6.

Alona, is this is a different bug or should be take care as part of this BZ ^^? 

Thanks,
Comment 2 Alona Kaplan 2015-11-16 07:10:17 EST
(In reply to Michael Burman from comment #1)
> In current version 3.6.0.1-0.1.el6 in clusters 3.5, 'passthrough' checkbox
> appears in vNIC profile dialog and 'pci-passthrough' type is part of the
> type list in vNIC's dialog. This should be disabled or shouldn't be exist at
> all for clusters below 3.6.
> 
> Alona, is this is a different bug or should be take care as part of this BZ
> ^^? 
> 
> Thanks,

different bug.
Comment 3 Michael Burman 2015-11-16 07:29:38 EST
(In reply to Alona Kaplan from comment #2)
> (In reply to Michael Burman from comment #1)
> > In current version 3.6.0.1-0.1.el6 in clusters 3.5, 'passthrough' checkbox
> > appears in vNIC profile dialog and 'pci-passthrough' type is part of the
> > type list in vNIC's dialog. This should be disabled or shouldn't be exist at
> > all for clusters below 3.6.
> > 
> > Alona, is this is a different bug or should be take care as part of this BZ
> > ^^? 
> > 
> > Thanks,
> 
> different bug.

Done. 

For second issue see BZ 1282441
Comment 4 Yaniv Lavi 2016-07-20 05:57:16 EDT
We will not resolve this since 4.0 only support 3.6>
Comment 5 Red Hat Bugzilla Rules Engine 2016-07-20 05:57:24 EDT
Planning has indicated this request is declined. You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.