Bug 1269445 - [RFE] WEB-UI: HTML5 Console - Responsive page rendering needs to be implemented for Web based HTML5 console
[RFE] WEB-UI: HTML5 Console - Responsive page rendering needs to be implement...
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: John Hardy
Dave Johnson
html5:console
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-07 07:30 EDT by Ramesh A
Modified: 2017-08-28 11:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-28 11:00:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Small Screen - normal browser view (357.88 KB, image/png)
2015-10-07 07:30 EDT, Ramesh A
no flags Details
Small Screen - F11 browser view (471.38 KB, image/png)
2015-10-07 07:30 EDT, Ramesh A
no flags Details
Large Screen - normal browser view (503.90 KB, image/png)
2015-10-07 07:31 EDT, Ramesh A
no flags Details

  None (edit)
Description Ramesh A 2015-10-07 07:30:01 EDT
Created attachment 1080619 [details]
Small Screen - normal browser view

Description of problem:
Responsive page rendering needs to be implemented for Web based HTML5 console

Version-Release number of selected component (if applicable):
5.4.3.0.20151001120745_d11cf59

How reproducible:
Very

Steps to Reproduce:
1. Configure HTML5 Console for the appliance
2. From Infrastructure ==> Virtual Machines ==> Select a vm
3. Click on the HTML 5 console icon

Actual results:
Rendered HTML5 console window is of fixed dimensions.  Its very difficult to operate the vm in the console as options are not visible in the smaller screens like 12" Laptop

Expected results:
Should be responsive according to the laptop/desktop screen dimension.

Additional info:
Comment 2 Ramesh A 2015-10-07 07:30 EDT
Created attachment 1080620 [details]
Small Screen - F11 browser view
Comment 3 Ramesh A 2015-10-07 07:31 EDT
Created attachment 1080621 [details]
Large Screen - normal browser view
Comment 5 Chris Pelland 2017-08-28 11:00:08 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.