Bug 126947 - Kernel 459 does not come up, Kernel 457 does not go down...
Kernel 459 does not come up, Kernel 457 does not go down...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-29 13:37 EDT by Bob Gustafson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-08 10:25:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is dmesg, dated 11:13 (assume that this is time of last entry) (23.06 KB, text/plain)
2004-07-02 13:28 EDT, Bob Gustafson
no flags Details

  None (edit)
Description Bob Gustafson 2004-06-29 13:37:15 EDT
Description of problem:

  I just did yum update of kernel 459 (incl .smp, etc.) and it does
not boot. Seems to fail at the 'nash ' stage of the boot process and
then reboots (continual cycle).

  Also, kernel 457 has a problem shutting down. The '/sbin/shutdown -r
now' process just hangs - presumably waiting for something to go.

Doing a kill -9 on various processes does not seem to work either.

Version-Release number of selected component (if applicable):


How reproducible:

  Unfortunately, continually for me.

Steps to Reproduce:
1. boot with kernel-smp-459
2.
3.
  
Actual results:


Expected results:


Additional info:

  I am running SELinux in permissive mode (both boot params and
/etc/selinux/config
Comment 1 Bob Gustafson 2004-07-01 21:00:33 EDT
Kernel 467 also does not come up. Recycles even earlier than the nash
stage..

I can send log files (if any) if desired
Comment 2 Bob Gustafson 2004-07-02 11:56:29 EDT
Even with updates to various components (kernel did not update this
morning), the kernel 467 still does not come up.

It fails somewhere in between the audit statement and the running of
Red Hat nash (system reboots between - and I don't see nash)

----

Currently running 457 kernel - shutdown still does not work on that
kernel.
Comment 3 Bob Gustafson 2004-07-02 12:33:25 EDT
I thought I would get more information by removing the 'silent' option
on the grub boot line for kernel-2.6.7-1.467smp, but did not get
anything illuminating.

A fragment of the /var/log/messages file is shown below. My comments
are indented 2 spaces on separate lines

  I am in kernel 457 and am manually killing off some daemons in
  the (unsuccessful) hope that I can shutdown cleanly.

Jul  2 11:03:26 hoho2 su: Killing Xvnc process ID 4057
Jul  2 11:03:26 hoho2 su(pam_unix)[6617]: session closed for user user1
Jul  2 11:03:26 hoho2 vncserver: vncserver shutdown succeeded
Jul  2 11:03:48 hoho2 httpd: httpd shutdown succeeded
Jul  2 11:04:31 hoho2 smartd[3627]: smartd received signal 15: Terminated
Jul  2 11:04:31 hoho2 smartd[3627]: smartd is exiting (exit status 0)
Jul  2 11:04:31 hoho2 smartd: smartd shutdown succeeded
Jul  2 11:04:46 hoho2 atd: atd shutdown succeeded
Jul  2 11:05:19 hoho2 shutdown: shutting down for system reboot

  Hit power button briefly

Jul  2 11:05:27 hoho2 shutdown: shutting down for system halt

  It did not shut down by itself, so pressed the power button longer
  and then system shutdown.

  Then I tried to reboot into kernel 467 with 'silent' removed
  from grub boot line.

  As you can see, NO lines were logged to messages.

  After being unsuccessful in booting 457, I went back to 457 and
  booted

Jul  2 11:13:51 hoho2 syslogd 1.4.1: restart.
Jul  2 11:13:51 hoho2 syslog: syslogd startup succeeded
Jul  2 11:13:51 hoho2 kernel: klogd 1.4.1, log source = /proc/kmsg
started.
Jul  2 11:13:51 hoho2 syslog: klogd startup succeeded
Jul  2 11:13:51 hoho2 kernel: Linux version 2.6.7-1.457smp
(bhcompile@porky.buil
Comment 4 Bob Gustafson 2004-07-02 13:28:31 EDT
Created attachment 101604 [details]
This is dmesg, dated 11:13 (assume that this is time of last entry)

This dmesg may have some clues as to what is preventing kernel-2.6.7-1.467 from
coming up on my system. However, since there are no timestamps in this file, it
may only cover the period where kernel-2.6.7-1.457 is coming up.
Comment 5 Bob Gustafson 2004-07-03 14:08:35 EDT
Hmm, with kernel-2.6.7-1.469smp, it does not come up, but using the SP
version, it does come up.

Also, the font problem I was having for the last couple of months
seems to have gone away. - See bug 122180

But, the smp kernel is what I need, so I will keep this bug in the
system..
Comment 6 Bob Gustafson 2004-07-03 14:26:36 EDT
Single processor kernel also does shutdown.

Also does shutdown right from gnome menu too (from console terminal)
even though logged in as a regular user.

Way to go.
Comment 7 Bob Gustafson 2004-07-06 13:49:23 EDT
Single processor kernel-471 comes up, but kernel-471smp still does not
boot.

[user2@hoho2 user2]$ cat /proc/version
Linux version 2.6.7-1.471 (bhcompile@daffy.perf.redhat.com) (gcc
version 3.4.1 20040702 (Red Hat Linux 3.4.1-1)) #1 Mon Jul 5 10:09:57
EDT 2004
[user2@hoho2 user2]$
Comment 8 Dave Jones 2004-07-07 07:32:00 EDT
Ok, I've spent the last two days chasing this as it bit one of my
boxes too. It's fixed on my system, and I believe the next kernel
should have this fixed for you too.
Comment 9 Bob Gustafson 2004-07-08 10:25:10 EDT
[user1@hoho2 user1]$ cat /proc/version
Linux version 2.6.7-1.476smp (bhcompile@daffy.perf.redhat.com) (gcc
version 3.4.1 20040702 (Red Hat Linux 3.4.1-2)) #1 SMP Wed Jul 7
14:56:17 EDT 2004
[user1@hoho2 user1]$

Seems to work pretty well - thanks much

Note You need to log in before you can comment on or make changes to this bug.