Bug 126958 - cman_tool leave force causes ccsd to die
Summary: cman_tool leave force causes ccsd to die
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: gfs   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Earl Brassow
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
: 126750 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-29 19:26 UTC by Derek Anderson
Modified: 2010-01-12 02:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-03 15:16:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Anderson 2004-06-29 19:26:46 UTC
Description of problem:
Start ccsd and run cman_tool join on a cluster node.  Exit cman with
'cman_tool leave force'.  At this point ccsd also exits.  Don't expect
it to do that.

[root@link-12 root]# ccsd -n
Starting ccsd DEVEL.1088539777:
 Built: Jun 29 2004 15:10:43
 Copyright (C) Red Hat, Inc.  2004  All rights reserved.
cluster.xml (cluster name = MILTON, version = 3) found.
No nodes found.
Error while processing get: No data available
No nodes found.
Error while processing get: No data available
No nodes found.
Error while processing get: No data available
No nodes found.
Error while processing get: No data available
No nodes found.
Error while processing get: No data available
No nodes found.
Error while processing get: No data available

### Run cman_tool leave force here ...
Unable to bind cluster socket: Transport endpoint is not connected
Exiting...
[root@link-12 root]#



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jonathan Earl Brassow 2004-06-29 21:23:37 UTC
ccsd will no longer exit when cman_tool leave is performed.  It will drop into a 
non-cluster mode - disallowing new connections until it can reestablish a 
connection with cman and determine quorum.

I also fixed the annoying "no data" messages.  These will only be printed if 
ccsd is run with the -v flag.

Comment 2 Jonathan Earl Brassow 2004-06-29 21:26:25 UTC
*** Bug 126750 has been marked as a duplicate of this bug. ***

Comment 3 Corey Marthaler 2004-09-03 15:16:08 UTC
fix verified.

Comment 4 Kiersten (Kerri) Anderson 2004-11-16 19:11:16 UTC
Updating version to the right level in the defects.  Sorry for the storm.


Note You need to log in before you can comment on or make changes to this bug.