Bug 1269843 - [webadmin] Selected display type is not supported by the operating system.
[webadmin] Selected display type is not supported by the operating system.
Status: CLOSED NEXTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.1
: ---
Assigned To: jniederm
Pavel Stehlik
virt
:
: 1269842 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 06:42 EDT by Jiri Belka
Modified: 2016-02-10 14:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 02:41:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.z?
jbelka: planning_ack?
jbelka: devel_ack?
jbelka: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2015-10-08 06:42:16 EDT
Description of problem:

I had a VM running on my 3.6 engine env (including RHEL7 hosts with 3.6 vdsm). I needed to test something so I modified this VM settings and changed cluster to another one with 3.5 cluster level and got this warning:

--->%---
	
Operation Canceled
Error while executing action:

jb-bz1:

    Cannot edit VM Cluster. Selected display type is not supported by the operating system.

---<%---

What is 'display type' in this context? There's no word 'display' in VM Settings/Console; this error causes big confusion! I have no idea what's wrong, SPICE is supported on 3.5 cluster and RHEL6 64bit OS type.

Changing QXL to Cirrus causes switch to VNC (not acceptable, 3.5 supports SPICE). Only SPICE is acceptable for me for this VM and I can't have SPICE for this VM, this is dumb. I can't even change to VNC!

--->%---
2015-10-08 12:40:09,115 DEBUG [org.ovirt.engine.core.bll.ChangeVMClusterCommand] (ajp-/127.0.0.1:8702-9) [175bfa86] Found permission '00000019-0019-0019-0019-000000000080' for user when running 'ChangeVMCluster',
 on 'VM' with id 'cb7315e0-e835-46f0-8088-fcf0858f04ca'
2015-10-08 12:40:09,117 DEBUG [org.ovirt.engine.core.bll.ChangeVMClusterCommand] (ajp-/127.0.0.1:8702-9) [175bfa86] Found permission '00000019-0019-0019-0019-000000000080' for user when running 'ChangeVMCluster',
 on 'Cluster' with id '4cd11758-7f8a-4e46-8c13-f58756c29f62'
2015-10-08 12:40:09,147 WARN  [org.ovirt.engine.core.bll.ChangeVMClusterCommand] (ajp-/127.0.0.1:8702-9) [175bfa86] CanDoAction of action 'ChangeVMCluster' failed for user admin@internal. Reasons: VAR__ACTION__UP
DATE,VAR__TYPE__VM__CLUSTER,ACTION_TYPE_FAILED_ILLEGAL_VM_DISPLAY_TYPE_IS_NOT_SUPPORTED_BY_OS
---<%---

Version-Release number of selected component (if applicable):
rhevm-webadmin-portal-3.6.0-0.18.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. 3.6 engine, 3.6 cluster, 3.6 host (RHEL7)
2. install RHEL6 64bit VM with _SPICE_
3. 3.5 cluster, 3.5 host/vdsm (RHEL6)
4. edit the installed VM settings while done and switch cluster to the 3.5 one

Actual results:
-     Cannot edit VM Cluster. Selected display type is not supported by the operating system.
- cannot get SPICE for this VM

Expected results:
should work, we support SPICE for ages

Additional info:
Comment 2 Jiri Belka 2015-10-08 08:42:28 EDT
*** Bug 1269842 has been marked as a duplicate of this bug. ***
Comment 3 Red Hat Bugzilla Rules Engine 2015-10-19 06:50:45 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 4 Yaniv Lavi (Dary) 2015-10-29 08:38:30 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 5 jniederm 2015-12-02 11:10:42 EST
Hi, I can't reproduce it. Can you please share osinfo properties file from failing engine setup?
Comment 6 Jiri Belka 2015-12-03 11:59:18 EST
(In reply to jniederm from comment #5)
> Hi, I can't reproduce it. Can you please share osinfo properties file from
> failing engine setup?

"failing engine setup" is dead for 2 months. i would recommend to close it as 'currentrelease' as in rhevm-3.6.1.1-0.1.el6.noarch it works ok. Thx.
Comment 7 Tomas Jelinek 2015-12-07 02:41:26 EST
According to both Comment 5 and 6 it works in 3.6.1, closing

Note You need to log in before you can comment on or make changes to this bug.