Bug 1269881 - dnf search backtrace (UnicodeEncodeError)
dnf search backtrace (UnicodeEncodeError)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
: EasyFix, i18n, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 08:15 EDT by Jan Synacek
Modified: 2016-08-01 06:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-01 04:33:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Synacek 2015-10-08 08:15:50 EDT
Description of problem:
See steps to reproduce.


Version-Release number of selected component (if applicable):
dnf-1.1.2-4.fc24.noarch


Steps to Reproduce:
1. # dnf search auto
<tons of packages listed>
...
Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 136, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1091, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/search.py", line 106, in run
    return self._search(extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/search.py", line 81, in _search
    args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 784, in matchcallback
    print(msg)
  File "/usr/lib/python3.4/site-packages/dnf/i18n.py", line 44, in write
    self.stream.write(s)
UnicodeEncodeError: 'ascii' codec can't encode character '\u2019' in position 52: ordinal not in range(128)


Actual results:
Backtrace.


Expected results:
No backtrace.
Comment 1 Honza Silhan 2015-10-13 10:21:43 EDT
Thanks for the report.
Comment 2 Jan Kurik 2016-02-24 08:49:16 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Fedora Admin XMLRPC Client 2016-07-08 05:31:17 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Štěpán Smetana 2016-08-01 04:33:59 EDT
Works for me.
Should be fixed in dnf-1.1.9 (Take a look at this commit https://github.com/rpm-software-management/dnf/commit/93159e360f0b6150e598bba783e22ca113201a40)
In case reopen this bug and provide more info.
Thanks

Note You need to log in before you can comment on or make changes to this bug.