Bug 126990 - system-config-display does not properly configure laptop projector, and emits error
system-config-display does not properly configure laptop projector, and emits...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-30 02:53 EDT by marius du plessis
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.0.37-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 15:28:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log and xorg.conf (60.00 KB, text/plain)
2004-06-30 07:30 EDT, marius du plessis
no flags Details
xconf.py script that causes error (14.39 KB, text/plain)
2004-06-30 08:40 EDT, marius du plessis
no flags Details
Xorg conf file (2.78 KB, text/plain)
2004-07-08 06:26 EDT, marius du plessis
no flags Details
X - log file (43.34 KB, text/plain)
2004-07-08 06:28 EDT, marius du plessis
no flags Details

  None (edit)
Description marius du plessis 2004-06-30 02:53:34 EDT
We are having problems with our hp vp6100 projector resolution
settings when connecting it to our notebooks (ranging in makes and
models from dell to fujitsu-siemens).  As soon as we plug it into our
machines, it only offers a 640x480 resolution.  It does however
support all resolutions up to 1280x1024 as well as the range of
frequencies that is set for the spesific machines. Also have to
mention that it works without hassles in other operating systems?!

The following fixes were recommended by xorg - 
1. edit xorg.conf and comment out the frequency ranges
2. restart with the projector connected

To no avail.  We tested both the original xorg.conf and the editted
version, but the projector only offers 640x480.
Comment 1 Mike A. Harris 2004-06-30 05:50:28 EDT
Sounds like this machine has Intel i8xx video hardware present in
it.  Could you please attach your xorg.conf and X server log file
from a failed attempt?

Thanks in advance.
Comment 2 marius du plessis 2004-06-30 06:12:57 EDT
Got the problem fixed on the Fujitsu machines - the machine(s) that
still gives the problem are Dell Laptops.  

I've in the mean time gone through your recommendations that has to do
with xpdyinfo and ddcprobe -  and the results on the dell are that the
screen size is calculated at 542x406mm.  The calculation is correct if
you work at 75x75dpi - but the dpi is far higher though in real terms.
 Where can I set these values and try to fix the problem??

ddcprobe failed as the LCD screen probably does not support it...
Comment 3 Mike A. Harris 2004-06-30 06:49:16 EDT
If there is a real bug present here which we need to investigate,
once you've attached the files I've requested in comment #1 above
I can look into the problem further.

You may wish to join some of the Red Hat or X related mailing lists
however if you require technical assistance or configuration help.

Comment 4 marius du plessis 2004-06-30 07:30:18 EDT
Created attachment 101534 [details]
Xorg log and xorg.conf

please find attached the Xorg.0.log as well as the xorg.conf files as
requested... thx..
Comment 5 Mike A. Harris 2004-06-30 08:01:49 EDT
Your config file is configured to force it to only use 640x480,
which is why that resolution is the only one you're seeing available.

Please run "system-config-display --reconfig" and generate a new
config file from scratch.  Test this file without editing it by
hand, and it should work.

If it doesn't, please attach the new X server config file and log
file as individual uncompressed file attachments, one attachment
per file.

Thanks in advance.
Comment 6 Mike A. Harris 2004-06-30 08:06:26 EDT
Just to illustrate the problem a bit more clearly, here's the
flawed config file section:


Section "Screen"

	SubSection "Display"             <-
		Viewport   0 0           <-
		Depth     16             <-
		Modes    "640x480"       <---- 640x480 right here
	EndSubSection                    <-
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1600x1200" "1400x1050" "1280x1024" "1280x960" "1024x768"
"800x600" "640x480"
	EndSubSection
EndSection

Comment 7 Mike A. Harris 2004-06-30 08:09:03 EDT
Additionally, the log file you've attached, shows it is using
1600x1200x24bit depth.  Did you attach the correct log file and
config file above from a non-working setup?
Comment 8 marius du plessis 2004-06-30 08:40:56 EDT
Created attachment 101535 [details]
xconf.py script that causes error

The specific subsection in question was removed in one of the testing sessions,
with still the same results. 

I've just rerun system-config-display... resulting in an error - 
 File "/usr/share/system-config-display/xconf.py", line 412, in ?
    hardware_state.merge_into(xconfig)
NameError: name 'hardware_state' is not defined

I've checked the script - "xconf.py" - hardware_state is also used in other
areas, which do not cause any problems?!  I've also checked the script on
another machine (server box) and they are identical - running it causes the
same error... I'm attaching the xconf.py for your input...
Comment 9 Mike A. Harris 2004-06-30 08:47:14 EDT
That's a bug in system-config-display or it's deps, not an xorg-x11
bug.  Reassigning to system-config-display component.
Comment 10 marius du plessis 2004-06-30 09:17:56 EDT
the log file and conf files are both from the same dell laptop giving
the problem and abovementioned error.  should I force the resolution
to 1024x768 in xorg.conf, reconnect to the projector and create a new
log file??  the previous log file was copied minutes after we
disconnected from the projector - without any changes to xorg.conf or
the resolution settings....
Comment 11 Mike A. Harris 2004-07-05 20:07:00 EDT
We need the log and config file from the configuration that is
causing the problem.  By examining the log file of the X server
which is not working properly, and comparing it with the config file,
it helps to determine wether it is a legitimate bug, or wether it
is just a configuration issue or limitation of the implementation,
or some other problem.

For ease of viewing, please attach the files as individual
uncompressed files, and we'll review them for troubleshooting
once you've updated the report.

Thanks for the report.
Comment 12 marius du plessis 2004-07-08 06:26:41 EDT
Created attachment 101719 [details]
Xorg conf file

here is the conf file for xorg...
Comment 13 marius du plessis 2004-07-08 06:28:17 EDT
Created attachment 101720 [details]
X - log file

the log file attached is one that was created from booting with the projector
connected.  the dell resolution was set at 1024x768...
Comment 14 Paul Nasrat 2004-10-13 05:12:18 EDT
Can you retest with FC3t3  or the most recent FC2
system-config-display erratum

run system-config-display --reconfig when the projector is attached -
attach the generated config 
Does the hardware_state error occur when you do that?
Comment 15 Adam Jackson 2006-03-22 15:28:41 EST
Reporter, please reopen if this is still an issue with FC3 or later.

Note You need to log in before you can comment on or make changes to this bug.