Bug 1269942 - OSP 6 installation failed with packstack
OSP 6 installation failed with packstack
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Martin Magr
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 10:19 EDT by Eran Kuris
Modified: 2016-04-18 02:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-03 03:40:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eran Kuris 2015-10-08 10:19:11 EDT
Description of problem:
I am trying to install with packstack OSP-6 on rhel 7 2 nodes setup
> > and I git this error 
 ERROR : Error appeared during Puppet run: 10.35.186.16_nova.pp
> > Error: /Stage[main]/Main/Exec[qemu-kvm]/onlyif: Check "yum install
> > -y -d 0 -e 0 qemu-kvm-rhev &> /dev/null && exit 1 || exit 0"
> > exceeded timeout
> > You will find full trace in log /var/tmp/packstack/20151008-025001
> > -v6iVMq/manifests/10.35.186.16_nova.pp.log
> > Please check log file /var/tmp/packstack/20151008-025001
> > -v6iVMq/openstack-setup.log for more information
> > Additional information:
> >  * Time synchronization installation was skipped. Please note that
> > unsynchronized time on server instances might be problem for some
> > OpenStack components.
> >  * Warning: NetworkManager is active on 10.35.186.159,
> > 10.35.186.16. OpenStack networking currently does not work on
> > systems that have the Network Manager service enabled.
> >  * File /root/keystonerc_admin has been created on OpenStack client
> > host 10.35.186.159. To use the command line tools you need to
> > source the file.
> >  * To access the OpenStack Dashboard browse to
> > http://10.35.186.159/dashboard .
> > Please, find your login credentials stored in the keystonerc_admin
> > in your home directory.
> >  * To use Nagios, browse to http://10.35.186.159/nagios username:
> > nagiosadmin, password: a8afb05a4ccf455f


"Filip Hubik" <fhubik@redhat.com>  saw this problem too 
Version-Release number of selected component (if applicable):

[root@osp-6--compute-1 ~]# rpm -qa |grep openstack
openstack-nova-cert-2014.2.3-29.el7ost.noarch
openstack-neutron-ml2-2014.2.3-12.el7ost.noarch
openstack-dashboard-theme-2014.2.3-7.el7ost.noarch
openstack-swift-object-2.2.0-4.el7ost.noarch
openstack-cinder-2014.2.3-6.el7ost.noarch
openstack-ceilometer-compute-2014.2.3-5.el7ost.noarch
openstack-puppet-modules-2014.2.15-4.el7ost.noarch
openstack-nova-compute-2014.2.3-29.el7ost.noarch
openstack-swift-2.2.0-4.el7ost.noarch
openstack-ceilometer-central-2014.2.3-5.el7ost.noarch
openstack-ceilometer-common-2014.2.3-5.el7ost.noarch
redhat-access-plugin-openstack-6.0.3-1.el7ost.noarch
openstack-swift-proxy-2.2.0-4.el7ost.noarch
openstack-ceilometer-alarm-2014.2.3-5.el7ost.noarch
openstack-nova-console-2014.2.3-29.el7ost.noarch
openstack-nova-scheduler-2014.2.3-29.el7ost.noarch
openstack-neutron-common-2014.2.3-12.el7ost.noarch
openstack-utils-2014.2-1.el7ost.noarch
openstack-glance-2014.2.3-2.el7ost.noarch
openstack-nova-common-2014.2.3-29.el7ost.noarch
openstack-packstack-2014.2-0.25.dev1474.gd85ee76.el7ost.noarch
openstack-swift-container-2.2.0-4.el7ost.noarch
python-openstackclient-1.0.1-1.el7ost.noarch
openstack-nova-conductor-2014.2.3-29.el7ost.noarch
openstack-neutron-2014.2.3-12.el7ost.noarch
openstack-ceilometer-collector-2014.2.3-5.el7ost.noarch
openstack-neutron-openvswitch-2014.2.3-12.el7ost.noarch
openstack-dashboard-2014.2.3-7.el7ost.noarch
openstack-swift-plugin-swift3-1.7-3.el7ost.noarch
openstack-ceilometer-notification-2014.2.3-5.el7ost.noarch
openstack-ceilometer-api-2014.2.3-5.el7ost.noarch
openstack-nova-novncproxy-2014.2.3-29.el7ost.noarch
openstack-keystone-2014.2.3-1.el7ost.noarch
python-django-openstack-auth-1.1.7-4.el7ost.noarch
openstack-swift-account-2.2.0-4.el7ost.noarch
openstack-nova-api-2014.2.3-29.el7ost.noarch
openstack-packstack-puppet-2014.2-0.25.dev1474.gd85ee76.el7ost.noarch
openstack-selinux-0.6.37-1.el7ost.noarch

How reproducible:


Steps to Reproduce:
1.packstack installation on rhel 7 
2.
3.

Actual results:

failed 
Expected results:

pass 
Additional info:
there is no ,more logs .
Comment 3 Valentina Mukhamedzhanova 2015-10-13 05:40:34 EDT
I'm not sure why this was reported against yum-utils, I'm moving this to openstack-packstack component, hopefully it's the right component for this bugzilla. If you believe this is a bug in yum (which I don't have reasons to believe so far) please provide an independent reproducer, a full yum output and a description of the expected result.
Comment 4 Ivan Chavero 2015-12-03 03:40:10 EST
This problem seems to be a like particular system misconfiguration

Note You need to log in before you can comment on or make changes to this bug.