Bug 126995 - Daemon dumps core while loading thru dlopen( DYNAMIC LINKER )
Daemon dumps core while loading thru dlopen( DYNAMIC LINKER )
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: glibc (Show other bugs)
2.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-30 05:48 EDT by satish chandra
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-25 17:29:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description satish chandra 2004-06-30 05:48:23 EDT
Description of problem:
Daemon dumps core while resolving for global symbols. 
Stack endups with in _dl_lookup_versioned_symbol 

(gdb) where
#0  0x40009b8b in _dl_lookup_versioned_symbol () at eval.c:41
#1  0x4000d2c6 in fixup () at eval.c:41
#2  0x4000d460 in profile_fixup () at eval.c:41
#3  0x4016a195 in __fork () at ptfork.c:96
#4  0x08052c5f in dump_core () at eval.c:41
#5  0x4016bba5 in pthread_key_delete (key=11) at specific.c:69
#6  0x401f7988 in __libc_sigaction (sig=135360156, act=0x1, oact=0x0)
    at ../sysdeps/i386/i486/bits/string.h:71
#7  0x4000d311 in fixup () at eval.c:41
#8  0x4000d460 in profile_fixup () at eval.c:41


Version-Release number of selected component (if applicable):

glibc-2.2.4-32.11.( ES2.1 & AS 2.1)

How reproducible:
Any loadable module which does symbol resolving should get
you this problem

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
I guess it would be fixed already look for right glibc version which
provides the fix.

Additional info:
Comment 1 Jakub Jelinek 2004-06-30 06:01:46 EDT
Current AS2.1 glibc is 2.2.4-32.16 (U4 has 2.2.4-32.15, still younger
than 32.11).
And certainly many loadable modules which do symbol resolving don't
get this problem.
Please provide a small self-contained testcase so that we can reproduce it.
Comment 2 Ulrich Drepper 2004-08-26 02:42:25 EDT
Ping!  Have you tried anything more recent?  I'll close the bug unless
we hear from you with more information.
Comment 3 Ulrich Drepper 2004-09-25 17:29:29 EDT
Closing since we have no more information.

Note You need to log in before you can comment on or make changes to this bug.