Bug 1270041 - osp-director python-rdomanager-oscplugin install fails using rhsm
osp-director python-rdomanager-oscplugin install fails using rhsm
Status: CLOSED WORKSFORME
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity medium
: ---
: 7.0 (Kilo)
Assigned To: wes hayutin
yeylon@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-08 17:24 EDT by wes hayutin
Modified: 2016-04-18 02:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 08:34:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2015-10-08 17:24:03 EDT
Description of problem:

osp-director virt install with RHSM pulling htb yum content repos

From: /home/stack/.instack/virt-setup.log

---> Package rsyslog.x86_64 0:7.4.7-7.el7_0 will be updated
---> Package rsyslog.x86_64 0:7.4.7-12.el7 will be an update


sudo yum install python-rdomanager-oscplugin.noarch
Loaded plugins: priorities, search-disabled-repos
Resolving Dependencies
--> Running transaction check
---> Package python-rdomanager-oscplugin.noarch 0:0.0.10-8.el7ost will be installed
<snip>>
--> Processing Dependency: python(x86-64) = 2.7.5-18.el7_1.1 for package: python-devel-2.7.5-18.el7_1.1.x86_64
---> Package rsyslog-mmjsonparse.x86_64 0:7.4.7-7.el7_0 will be installed
--> Processing Dependency: rsyslog = 7.4.7-7.el7_0 for package: rsyslog-mmjsonparse-7.4.7-7.el7_0.x86_64
--> Finished Dependency Resolution
Error: Package: rsyslog-mmjsonparse-7.4.7-7.el7_0.x86_64 (rhel-7-server-rpms)
           Requires: rsyslog = 7.4.7-7.el7_0
           Installed: rsyslog-7.4.7-12.el7.x86_64 (@rhel-7-server-htb-rpms)
               rsyslog = 7.4.7-12.el7
           Available: rsyslog-7.4.7-6.el7.x86_64 (rhel-7-server-rpms)
               rsyslog = 7.4.7-6.el7
           Available: rsyslog-7.4.7-7.el7_0.x86_64 (rhel-7-server-rpms)
               rsyslog = 7.4.7-7.el7_0
Error: Package: python-devel-2.7.5-18.el7_1.1.x86_64 (rhel-7-server-rpms)
           Requires: python(x86-64) = 2.7.5-18.el7_1.1
           Installed: python-2.7.5-33.el7.x86_64 (@rhel-7-server-htb-rpms)
               python(x86-64) = 2.7.5-33.el7
           Available: python-2.7.5-16.el7.x86_64 (rhel-7-server-rpms)
               python(x86-64) = 2.7.5-16.el7
           Available: python-2.7.5-18.el7_1.1.x86_64 (rhel-7-server-rpms)
               python(x86-64) = 2.7.5-18.el7_1.1
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: rsyslog-mmjsonparse-7.4.7-7.el7_0.x86_64 (rhel-7-server-rpms)
           Requires: rsyslog = 7.4.7-7.el7_0
           Installed: rsyslog-7.4.7-12.el7.x86_64 (@rhel-7-server-htb-rpms)
               rsyslog = 7.4.7-12.el7
           Available: rsyslog-7.4.7-6.el7.x86_64 (rhel-7-server-rpms)
               rsyslog = 7.4.7-6.el7
           Available: rsyslog-7.4.7-7.el7_0.x86_64 (rhel-7-server-rpms)
               rsyslog = 7.4.7-7.el7_0
Error: Package: python-devel-2.7.5-18.el7_1.1.x86_64 (rhel-7-server-rpms)
           Requires: python(x86-64) = 2.7.5-18.el7_1.1
           Installed: python-2.7.5-33.el7.x86_64 (@rhel-7-server-htb-rpms)
               python(x86-64) = 2.7.5-33.el7
           Available: python-2.7.5-16.el7.x86_64 (rhel-7-server-rpms)
               python(x86-64) = 2.7.5-16.el7
           Available: python-2.7.5-18.el7_1.1.x86_64 (rhel-7-server-rpms)
               python(x86-64) = 2.7.5-18.el7_1.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 3 wes hayutin 2015-10-08 17:29:09 EDT
AFAICT, even though the correct repos are enabled some how the HTB high touch beta content is installed with the employee id/passwd
Comment 4 wes hayutin 2015-10-08 17:36:32 EDT
I'm emailing the subscription manager guys to try and find another account to rule out at least one variable.
Comment 5 Ben Nemec 2015-10-09 10:40:19 EDT
I'm fairly certain we are not enabling any htb repos in dib, so I have to think they got turned on by default somehow.  Maybe we should be doing "sudo subscription-manager repos --disable=*" in the rhel-registration script as is documented in https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Registering_your_System.html
Comment 7 James Slagle 2015-10-14 15:23:37 EDT
wes, i'm pretty sure the root cause is the htb repos being enabled when they shouldn't be. i'm going to assign this one to you while you track it down with the subscription manager folks. feel free to reassign back if it turns out to be an issue with director specifically.
Comment 8 Johan Swensson 2015-10-24 14:28:19 EDT
I'm currently seeing this as well but with locally synced repos, no HTB repos enabled.
Comment 9 Johan Swensson 2015-10-24 14:58:08 EDT
(In reply to Johan Swensson from comment #8)
> I'm currently seeing this as well but with locally synced repos, no HTB
> repos enabled.

Never mind, turns out I accidentally downloaded the RHEL 7.2 guest image which ships with a newer python. Sorry about the noise.
Comment 10 wes hayutin 2016-01-07 12:33:59 EST
I had this working a few weeks ago, will double check it.

Note You need to log in before you can comment on or make changes to this bug.