Bug 1270225 - Failed to register to RHN via RHEVH TUI
Failed to register to RHN via RHEVH TUI
Status: CLOSED DUPLICATE of bug 1259499
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.6.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Ryan Barry
yileye
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-09 06:25 EDT by yileye
Modified: 2016-02-10 15:03 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-09 06:31:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport and /var/log/* in file (5.50 MB, application/x-bzip)
2015-10-09 06:25 EDT, yileye
no flags Details

  None (edit)
Description yileye 2015-10-09 06:25:02 EDT
Created attachment 1081259 [details]
sosreport and /var/log/* in file

Description of problem:

Failed to register to RHN via TUI with correctly username and password in 'Rhev-
hypervisor7-7.2-20150928.0 

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-20150928.0 
ovirt-node-3.3.0-0.10.20150928gite7ee3f1.el7ev.noarch


How reproducible:
100%

Steps to Reproduce:
1.TUI clean install rhev-hypervisor7-7.2-20150928.0 successful with no error
2.IN ‘Network‘ Page,Enable NIC via DHCP.
3.Enter the  ‘RHN Registration’ page ,Input correctly username and password,like username: XXX,password: XXX
4.Click ‘Save’

Actual results:
after step4, output some error message:

 Transaction: Updating RHN configuration
 │
 │
 │
 │
 │
 │Checking pre-conditions ...
 │
 │(1/3) Removing old configuration
 │
 │(2/3) Preparing for registration
 │
 │(3/3) Registering to server
 │
 │
 │
 │An error occurred while applying the changes:
 │
 │'dict' object has no attribute 'startswith'  


Expected results:
It can be successful with no error.

Additional info:
# ovirt-node.log
<snip>
2015-10-08 02:57:59,782       INFO /usr/sbin/subscription-manager register --force --password XXXXXXXX --username qa@redhat.com
2015-10-08 02:58:40,987       INFO Captured nothing
2015-10-08 02:58:40,988       INFO An exception during the transaction: 'dict' object has no attribute 'startswith'
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ovirt/node/ui/__init__.py", line 949, in __run_transaction
    self.plugin.dry_or(lambda: tx_element.commit())
  File "/usr/lib/python2.7/site-packages/ovirt/node/plugins.py", line 188, in dry_or
    return func()
  File "/usr/lib/python2.7/site-packages/ovirt/node/ui/__init__.py", line 949, in <lambda>
    self.plugin.dry_or(lambda: tx_element.commit())
  File "/usr/lib/python2.7/site-packages/ovirt/node/setup/rhn/rhn_model.py", line 467, in commit
    Config().persist(cfg)
  File "/usr/lib/python2.7/site-packages/ovirt/node/utils/fs/__init__.py", line 421, in persist
    abspath = os.path.abspath(path)
  File "/usr/lib64/python2.7/posixpath.py", line 352, in abspath
    if not isabs(path):
  File "/usr/lib64/python2.7/posixpath.py", line 61, in isabs
    return s.startswith('/')
AttributeError: 'dict' object has no attribute 'startswith'
2015-10-08 02:58:41,036       INFO Changes were merged successfully
</snip>
Comment 1 Fabian Deutsch 2015-10-09 06:31:35 EDT

*** This bug has been marked as a duplicate of bug 1259499 ***

Note You need to log in before you can comment on or make changes to this bug.