Bug 1270226 - heat orchestration service provisioning error
heat orchestration service provisioning error
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.0
Assigned To: Bill Wei
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-09 06:29 EDT by Aziza Karol
Modified: 2016-06-29 05:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 09:58:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
catalog item (87.87 KB, image/png)
2015-10-09 06:29 EDT, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2015-10-09 06:29:54 EDT
Created attachment 1081260 [details]
catalog item

Description of problem:


Version-Release number of selected component (if applicable):
5.4.3

How reproducible:
100%

Steps to Reproduce:
1.create a service dialog base on heat orchestration template

2.create a catalog item type of orchestration and use the above dialog and select provider openstack. see attached screenshot.
Entrypoint:Cloud/Orchestration/Provisioning/StateMachines/Provision/default

3.order the service

Actual results:
ERROR  <MiqException::MiqOrchestrationProvisionError>: <MiqException::ServiceNotAvailable>/var/www/miq/lib/openstack/openstack_handle/handle.rb:74:in `rescue in raw_connect'

Expected results:


Additional info:
Comment 3 Bill Wei 2015-10-12 15:01:38 EDT
From the log the program correctly caught and handled errors. There was an error trying to connect to the openstack provider. It could be either the provider was down at the testing moment or the provider did not have Orchestration service enabled. 

You should double check whether the provider has orchestration service enabled. Then try again when the provider is healthy. Or you can test this against another OpenStack provider.

We can close this BZ unless the problem was not caused by above mentioned reasons.

Note You need to log in before you can comment on or make changes to this bug.