Bug 127030 - Conflicting entries for .eps in gnome-mime-data and shared-mime-info
Conflicting entries for .eps in gnome-mime-data and shared-mime-info
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-mime-data (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-30 16:05 EDT by Gérard Milmeister
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 17:22:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gérard Milmeister 2004-06-30 16:05:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Galeon/1.3.15

Description of problem:
.eps files are registered as application/postscript in gnome-vfs-mime,
however in /usr/share/mime/packages/freedesktop.org.xml it is under
image/x-eps, which I think is the correct one. This cause problems
with nautilus. Clicking on a .eps file results in a popup with

The filename "Uebung4b.eps" indicates that this file is of type
"(null)". The contents of the file indicate that the file is of type
"PostScript document". If you open this file, the file might present a
security risk to your system.

The properties dialog has Type: PostScript document and MIME type:
application/postscript.

Note, that if .eps is definitely image/x-eps, then the application
registry for ggv etc... should also be changed.


Version-Release number of selected component (if applicable):
gnome-mime-data-2.4.1-4

How reproducible:
Always

Steps to Reproduce:
N/A

    

Additional info:
Comment 1 Mike Ulrich 2004-08-30 18:17:56 EDT
Here's a workaround:

mike@box:/usr/share/mime/packages $cat Override.xml
<?xml version="1.0" encoding="UTF-8"?>
<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
  <mime-type type="application/postscript">
    <comment>PostScript document</comment>
    <comment xml:lang="no">PostScript-dokument</comment>
    <comment xml:lang="sv">PostScript-dokument</comment>
    <magic priority="50">
      <match offset="0" type="string" value="\004%!" />
      <match offset="0" type="string" value="%!" />
    </magic>
    <glob pattern="*.ps" />
    <glob pattern="*.eps" />
    <glob pattern="*.epsi" />
    <glob pattern="*.epsf" />
  </mime-type>
</mime-info>
mike@box:/usr/share/mime/packages $sudo update-mime-database
/usr/share/mime

This makes EPS files application/postscript.  It's wrong, but it shuts
nautilus up.

I think nautilus is using a different repository to determine the file
type from the magic.  If I run 'file' against an EPS file, it
indicates a mime type of application/postscript, but its magic shows
that it's in fact EPS.  Hopefully this will be worked out when Gnome
moves entirely to freedesktop, in 2.8.
Comment 2 Matthew Miller 2005-04-26 11:41:09 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 3 Ray Strode [halfline] 2005-05-11 17:22:58 EDT
Hi,

This bug is being closed because it has been in the NEEDINFO state for a long
time now.  Feel free to reopen the bug report if the problem still happens for
you and you can provide any information that was requested.

Note You need to log in before you can comment on or make changes to this bug.