Bug 1270583 - Vm nic unplugged after previewing/undoing a snapshot
Vm nic unplugged after previewing/undoing a snapshot
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.0.1
Unspecified Unspecified
high Severity urgent (vote)
: ovirt-3.6.1
: 3.6.1.1
Assigned To: Martin Mucha
Michael Burman
network
: Automation, Regression
: 1272056 1286687 1293297 (view as bug list)
Depends On:
Blocks: 1213937
  Show dependency treegraph
 
Reported: 2015-10-11 08:59 EDT by Raz Tamir
Modified: 2016-02-10 14:15 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:23:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
ylavi: planning_ack+
danken: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
engine log (689.34 KB, text/plain)
2015-10-11 08:59 EDT, Raz Tamir
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47899 master MERGED core: 'revert' of 2f471d83d145d7bc6674c6039bf7f8d1ba9ed137 Never
oVirt gerrit 49120 ovirt-engine-3.6 ABANDONED core: 'revert' of 2f471d83d145d7bc6674c6039bf7f8d1ba9ed137 Never
oVirt gerrit 49121 ovirt-engine-3.6.1 MERGED core: 'revert' of 2f471d83d145d7bc6674c6039bf7f8d1ba9ed137 Never
oVirt gerrit 49154 ovirt-engine-3.6 MERGED core: 'revert' of 2f471d83d145d7bc6674c6039bf7f8d1ba9ed137 Never

  None (edit)
Description Raz Tamir 2015-10-11 08:59:12 EDT
Created attachment 1081794 [details]
engine log

Description of problem:
When previewing a vm snapshot, the vm nic is unplugged


Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.18.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. create a vm with 1 disk
2. make snapshot
3. preview the snapshot

Actual results:
The vm nic is unplugged


Expected results:


Additional info:
Comment 1 Oved Ourfali 2015-10-11 09:04:53 EDT
Raz, this should both have network whiteboard, and on BLL.Network component. 
Please fix that.
Comment 2 Raz Tamir 2015-10-11 09:08:56 EDT
Done
Comment 3 Raz Tamir 2015-10-12 15:44:29 EDT
Also happens after undoing a previewed snapshot
Comment 4 Dan Kenigsberg 2015-10-22 05:17:04 EDT
*** Bug 1272056 has been marked as a duplicate of this bug. ***
Comment 5 Carlos Mestre González 2015-10-27 06:31:02 EDT
Hi,

The vm nic is also unplugged after a vm is imported, reproducible 100% in 3.6.0-17 build RHEL 7.2.

@Barak: Should I open a new bug or do you think this issue has the same root cause?
Comment 6 Carlos Mestre González 2015-10-28 11:17:09 EDT
Hi,

could you reply to comment 5?
Comment 7 Yaniv Lavi (Dary) 2015-10-29 08:39:29 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 8 Martin Mucha 2015-10-30 08:55:47 EDT

in reply to comment5: it's very probable, that this has the same cause. I just need to do some testing and patch should be ready.

please when testing this, you might want to retest scenarion in bug https://bugzilla.redhat.com/1212461
since changes there caused this issue.
Comment 9 Sandro Bonazzola 2015-12-01 10:07:31 EST
This bug is referenced in git log for ovirt-engine-3.6.1.1.
Please set target release to 3.6.1.1 accordingly unless additional patches are needed.
Comment 10 Alona Kaplan 2015-12-02 03:50:22 EST
*** Bug 1286687 has been marked as a duplicate of this bug. ***
Comment 11 Gilad Lazarovich 2015-12-02 07:57:10 EST
Please note that I'm also hitting his issue with VMs imported from an export domain (I verified that the original VM has a plugged NIC)
Comment 12 Red Hat Bugzilla Rules Engine 2015-12-03 08:13:59 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 13 Red Hat Bugzilla Rules Engine 2015-12-03 08:14:36 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 14 Michael Burman 2015-12-06 03:50:39 EST
Verified on - 3.6.1.1-0.1.el6
Comment 15 Sandro Bonazzola 2015-12-16 07:23:45 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.
Comment 16 Dan Kenigsberg 2015-12-21 09:40:47 EST
*** Bug 1293297 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.