Bug 1270593 - Foto flash card in card reader shows no fotos
Foto flash card in card reader shows no fotos
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-11 10:30 EDT by joerg.lechner
Modified: 2016-09-24 03:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-24 03:28:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
no eject of flash card in printer-scanner Canon Pixma MP540 (53.34 KB, image/jpeg)
2015-10-17 06:05 EDT, joerg.lechner
no flags Details

  None (edit)
Description joerg.lechner 2015-10-11 10:30:03 EDT
Description of problem:
When plug in the flash card (Sandisk Extreme 8GB) into the card slot of my Acer laptop, there is a message "card recognized". When I open the file menue I can see my disks but I can not see the flash card. Naturally "Rapid Foto Downloader" and "Shotwell" do not display or copy fotos. In the same system in F22 the flash card is ok, in F22 Rapid Foto Downloader and Shotwell copies the fotos and displays (It's the same hardware, internal card reader of the laptop, F22 and F23 on seperate external disks)


Version-Release number of selected component (if applicable):
Kernel 4.2.3-300.Fc23 x86_64

How reproducible:
always

Steps to Reproduce:
1. boot F23 Final TC1 Kernel 4.2.3-300.Fc23 x86_64
2. plug in foto flash card
3. look at file menue or start Rapid Foto Downloader or Shotwell

Actual results:
 flash card not displayed in file menue

Expected results:
 fotos can be downloaded

Additional info:
Comment 1 joerg.lechner 2015-10-11 11:08:58 EDT
The same sd card put in the card slot of the Canon scanner-printer (connected via usb to the system) is ok. Possible to handle with Shotwell, Rapid Foto Downloader does still not work (seems to be a problem of Rapid Foto Downloader). The SD card is displayed in the File menue.
Comment 2 Jarod Wilson 2015-10-13 18:30:53 EDT
Wrong component. Reassigning to kernel.
Comment 3 joerg.lechner 2015-10-17 06:05 EDT
Created attachment 1083900 [details]
no eject of flash card in printer-scanner Canon Pixma MP540

F23 Final Desktop TC11 x86_64, Kernel Version: 4.2.3 Release: 300.fc23. Photo Flash Card in Card Reader of printer-scanner Canon Pixma MP540, photos can be read and displayed, but it's not possible to eject the card via F23 file menue display.
Comment 4 joerg.lechner 2015-11-01 08:22:52 EST
just to note: My card reader in the Acer Laptop is a Realtek PCIE card reader.
I also can not display the laptop internal card reader and plugged SD card in lshw. But lshw shows the card reader and pugged SD card of my Canon printer-scanner.
Comment 5 joerg.lechner 2015-11-02 03:48:50 EST
I have just found that this problem of a Realtek Card reader seems to be
more generic in Linux, I found    
https://bugzilla.kernel.org/show_bug.cgi?id=57061
which talks about  rtsx_pci
and rts_bpp. Kernel is really not my area - I am more user, and a little bit
testing. Does anyone know the corresponding modules in F23, because this can be
the answer of my card reader problem
Comment 6 joerg.lechner 2015-11-02 06:04:04 EST
found a redhat bugzilla bug concerning similar  data:
my problem:lspci shows:
[ff00]: Realtek Semiconductor Co., Ltd. Device 5287 (rev 01)"
--> Gnome problem because of Kernel

old fedora bug:
Bug 854762 - rts_bpp: Realtek 5289 SD card reader does not work 
Status: 	CLOSED INSUFFICIENT_DATA

Possibly we can find now sufficient data.
Comment 7 Laura Abbott 2016-09-23 15:52:05 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 8 joerg.lechner 2016-09-24 03:28:25 EDT
Problem solved, You can close this bug

Note You need to log in before you can comment on or make changes to this bug.