Bug 1270602 - qtwebkit-5.5.1 no longer defines QTWEBKIT_VERSION_CHECK macro
qtwebkit-5.5.1 no longer defines QTWEBKIT_VERSION_CHECK macro
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt5-qtwebkit (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
https://apps.fedoraproject.org/kosche...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-11 14:13 EDT by Raphael Groner
Modified: 2015-10-12 12:04 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-12 12:04:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raphael Groner 2015-10-11 14:13:36 EDT
Description of problem:
Package qupzilla fails to build from source in rawhide.

Version-Release number of selected component (if applicable):
1.8.6-7.fc24

Steps to Reproduce:
koji build --scratch f24 qupzilla-1.8.6-7.fc24.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://apps.fedoraproject.org/koschei/package/qupzilla

This seems to be related to some incomplete qtwebkit header cause of the failing macro QTWEBKIT_VERSION_CHECK.
Comment 2 Rex Dieter 2015-10-12 08:53:10 EDT
qupzilla:

%changelog
* Mon Oct 12 2015 Rex Dieter <rdieter@fedoraproject.org> 1.8.7-2
- workaroung qtwebkit-5.5.1 dropping QTWEBKIT_VERSION_CHECK macro (#1270602)


In the meantime, will poke qtwebkit upstream to verify if this (arguably incompatible) change was intentional.
Comment 3 Rex Dieter 2015-10-12 12:04:28 EDT
Looks like removal was on purpose,

http://code.qt.io/cgit/qt/qtwebkit.git/commit/?h=5.5&id=c3e58209d3601d86eeacde7abeeb39eb67a5aaf3

I'd suggest poking qupzilla upstream about this issue, they can either take the workaround patch I made, or come up with some better solution

Note You need to log in before you can comment on or make changes to this bug.