Bug 1270603 - No check_linux_raid (software-raid) provided by nagios-plugins 2.x
No check_linux_raid (software-raid) provided by nagios-plugins 2.x
Status: CLOSED UPSTREAM
Product: Fedora EPEL
Classification: Fedora
Component: nagios-plugins (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen John Smoogen
Fedora Extras Quality Assurance
: Reopened
: 1270895 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-11 14:35 EDT by Stefan Neufeind
Modified: 2017-06-29 14:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-29 14:46:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2015-10-11 14:35:20 EDT
The 1.x-series had a check_linux_raid-plugin which automatically got removed upon upgrading to version 2.x. But there seems to be no replacement?

There is a generic raid-check available at
https://github.com/glensc/nagios-plugin-check_raid
But I expect that might not have been bundled because it might have relations to proprietary raid-tools? Otherwise, maybe that would be an option to check "any" raid not just software-raid.
Comment 1 Scott Wilkerson 2016-02-04 13:17:48 EST
*** Bug 1270895 has been marked as a duplicate of this bug. ***
Comment 2 Scott Wilkerson 2016-02-04 13:22:56 EST
Obsoletes were added in 2.0.3-2 by Kevin Fenzi
Comment 3 Erik M Jacobs 2016-03-08 09:11:33 EST
[root@dumpster ~]# yum provides '/usr/lib*/*check_raid'
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: mirror.eboundhost.com
 * epel: reflector.westga.edu
 * extras: mirror.atlantic.net
 * rpmforge: mirror.teklinks.com
 * updates: mirror.eboundhost.com
No Matches found
[root@dumpster ~]# yum provides '*check_raid'
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: mirror.eboundhost.com
 * epel: reflector.westga.edu
 * extras: mirror.atlantic.net
 * rpmforge: mirror.teklinks.com
 * updates: mirror.eboundhost.com
No Matches found


What do you mean "obsoletes were added"? nothing with "check_raid" seems to appear.

[root@dumpster ~]# yum list '*nagios*' | grep -i raid
[root@dumpster ~]# 

No nagios plugin with raid seems to be included.

What exactly was added? I see the changelog here:

* Thu Aug 27 08:00:00 2015 Kevin Fenzi <kevin@scrye.com> 2.0.3-2
- Add obsoletes for nagios-plugin-linux_raid < 1.4.3-11
- Fixes bug #1256682

But that doesn't actually tell me anything, and there's no raid plugin included in the nagios-plugins package:

[root@dumpster ~]# rpm -ql nagios-plugins
/usr/lib64/nagios/plugins/negate
/usr/lib64/nagios/plugins/urlize
/usr/lib64/nagios/plugins/utils.sh
/usr/share/doc/nagios-plugins-2.0.3
/usr/share/doc/nagios-plugins-2.0.3/ACKNOWLEDGEMENTS
/usr/share/doc/nagios-plugins-2.0.3/AUTHORS
/usr/share/doc/nagios-plugins-2.0.3/CODING
/usr/share/doc/nagios-plugins-2.0.3/COPYING
/usr/share/doc/nagios-plugins-2.0.3/ChangeLog
/usr/share/doc/nagios-plugins-2.0.3/FAQ
/usr/share/doc/nagios-plugins-2.0.3/LEGAL
/usr/share/doc/nagios-plugins-2.0.3/NEWS
/usr/share/doc/nagios-plugins-2.0.3/README
/usr/share/doc/nagios-plugins-2.0.3/README.Fedora
/usr/share/doc/nagios-plugins-2.0.3/REQUIREMENTS
/usr/share/doc/nagios-plugins-2.0.3/SUPPORT
/usr/share/doc/nagios-plugins-2.0.3/THANKS
/usr/share/locale/de/LC_MESSAGES/nagios-plugins.mo
/usr/share/locale/fr/LC_MESSAGES/nagios-plugins.mo

If it's obsolete, why is it obsolete? What replaces it?
Comment 4 Kevin Fenzi 2016-03-08 15:18:40 EST
My understanding is that nothing replaces it. It no longer exists upstream... 

But I was just pushing a security update, you will need to ask Scott Wilkerson (the current maintainer) what the status is for sure.
Comment 5 Erik M Jacobs 2016-03-08 16:25:47 EST
Where was the original upstream? Is it the one referenced in comment #1?
Comment 6 Kevin Fenzi 2016-03-09 11:26:05 EST
Upstream is https://www.nagios-plugins.org/ 

In the 1.4.x version of nagios-plugins there was a check_linux_raid. In the 2.0 release there is not. I don't know why they dropped the plugin, you would need to ask them, but it's simply no longer part of the software they release.
Comment 7 Erik M Jacobs 2016-03-09 13:56:32 EST
With nagios-plugins 1.5 2nd October 2013 the "contrib" folder was deleted:

        The contrib directory has been removed from this distribution

check_linux_raid was actually a perl script (not written in C) that was essentially Linux-only, so it was dropped from the "official" package. It is still, however, an actively maintained plugin judging from the source code upstream:

https://github.com/glensc/nagios-plugin-check_raid

Since this is EPEL and not RHEL, it begs the question of whether or not we want to be packaging any "additional" plugins from the Nagios exchange outside of the "official" packaged plugins.

As I am not a package maintainer I do not know how to answer that question.

So, yes, the plugin was made "obsolete" by the removal of the "contrib" folder from the "official" plugin tarball from nagios-plugins. But the plugin itself is not obsolete and is marked as working with all current versions of Nagios...
Comment 8 Stefan Neufeind 2016-03-10 03:57:02 EST
We could keep the existing ("official") package and add a nagios-plugins-extra or whatsoever with this and possible maybe at some point other plugins that get pulled in from separate sources.
Comment 9 Erik M Jacobs 2016-03-10 09:07:20 EST
I'm in favor of this idea but not sure who would take on the project. Unfortunately as upstream is no longer "packaging" contributions, we would essentially need to pick/choose what plugins we are supporting from the exchange or other sources.

Personally I think a big "extra" package might be troublesome to actually package, whereas individual extras packages might be a little easier to deal with.

For example: nagios-plugins-extra-check_linux_raid would only have that one plugin.

This would be similar to the existing packaging scheme, and individual contributors could package as many individual plugins as they like. This would also potentially work for both Fedora and EPEL.

Thoughts?
Comment 10 Stephen John Smoogen 2017-02-14 21:12:47 EST
I am not sure about where this problem goes at the moment. Has anyone looked at the plugins at https://www.monitoring-plugins.org/news/index.html to see if they would be a fix for the problems?
Comment 11 Stefan Neufeind 2017-02-15 02:45:48 EST
@Stephen: They also seem to have nothing related to linux-raid, do they? https://github.com/monitoring-plugins/monitoring-plugins
Comment 12 Stephen John Smoogen 2017-02-15 08:53:35 EST
Sigh I misread one of their module names.. never mind :).
Comment 13 Stephen John Smoogen 2017-06-29 14:46:51 EDT
OK, I have opened up the following ticket upstream https://github.com/nagios-plugins/nagios-plugins/issues/295 for them to talk about reimplementing the rules. Because they see this as a feature request, I don't think it will be something we should track here beyond a "CLOSED UPSTREAM" at the moment.

Note You need to log in before you can comment on or make changes to this bug.