Bug 1270618 - [DOCS] [3.1] [Feature] Document the various improvements to the Installer
[DOCS] [3.1] [Feature] Document the various improvements to the Installer
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Alex Dellapenta
Gaoyun Pei
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-11 19:26 EDT by Vikram Goyal
Modified: 2017-03-08 13 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 12:55:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vikram Goyal 2015-10-11 19:26:38 EDT
There are several improvements coming in the Installer for 3.1 (using the script):

* removal of the cntl-d escape
* ability to uninstall
* ability to add additional nodes post installation

(the last one seems to be delayed and may not make it for 3.1)

Check the productization board:
https://trello.com/b/wJYDst6C/productization
Comment 2 brice 2015-10-15 01:20:40 EDT
Trello card for adding additional nodes:

https://trello.com/c/IEkIu7n2/40-8-oo-install-support-for-adding-nodes-scale-up
Comment 3 Brenton Leanhardt 2015-10-15 08:37:48 EDT
We'll definitely have the ability to add nodes post install.  The other two will likely miss official devcut but should make it as well.  What "removal of the cntl-d escape" means is simply that the UI for entering hostnames will be different.  This isn't really something worth calling out in my opinion.  I would just put it in a bucket of general usability improvements.

One thing I mentioned to Alex that should be documented is that we're planning to do away with the "curl to your shell" install method.  We're going to ship a container that includes the installer wizard and the ansible playbook.  Admins could technically yum install the installer too.  That should settle within a week or so and you should have something to try out.
Comment 4 Jason DeTiberus 2015-10-15 11:06:42 EDT
We can use https://github.com/openshift/openshift-ansible/blob/master/playbooks/adhoc/atomic_openshift_tutorial_reset.yml as the starting point for the official uninstall.
Comment 5 brice 2015-10-15 23:30:07 EDT
Brenton, thanks for that. I'll talk to Alex and see if he's got something going on for the new installer. 

Jason, that link would be good to provide some context. I don't suppose there's more information? Say a possible use case (even I'm confused why we'd want to plug a uninstaller) and how to implement it? 

Thanks for the help, guys!
Comment 6 Jason DeTiberus 2015-10-22 16:42:35 EDT
Brice,

Brenton has a PR to generalize the uninstall playbook here: https://github.com/openshift/openshift-ansible/pull/713
Comment 7 Brenton Leanhardt 2015-10-22 17:03:08 EDT
We're still hoping to add support to the installer wizard for this too.
Comment 8 brice 2015-10-22 20:01:01 EDT
Jason, Brenton, I forgot to mention that Alex is going to take care of this card with his installer work on this BZ:

https://bugzilla.redhat.com/show_bug.cgi?id=1267431

I'll change the assignee over.
Comment 9 Alex Dellapenta 2015-11-05 23:07:42 EST
Some pieces of this have merged, still working on it:

https://docs.openshift.com/enterprise/3.1/install_config/install/quick_install.html
Comment 10 Alex Dellapenta 2015-11-12 17:47:51 EST
This can be reviewed now in the 3.1 Preview build:

https://docs.openshift.com/enterprise/3.1/install_config/install/quick_install.html
Comment 11 Ma xiaoqiang 2015-11-16 00:38:15 EST
I am only  focused on the ansible installation. Not clear about these content in https://docs.openshift.com/enterprise/3.1/install_config/install/quick_install.html.

thanks
Comment 13 Ma xiaoqiang 2015-11-16 04:28:44 EST
I have reviewed advanced installation, there is no issue.
Comment 14 Alex Dellapenta 2015-11-16 08:15:50 EST
This BZ was meant to cover the improvements to the installation utility (atomic-openshift-utils, f/k/a oo-install), as documented in the Quick Installation method.

Xiaoqiang, when you say you are only focused on the Ansible installation, are you saying you only QE the Advanced Installation and I should be pinging someone else for review of the Quick Installation? I was using the matrix in https://mojo.redhat.com/docs/DOC-1026387 to find a QE contact.

What is not clear about the Quick Installation topic?

Thanks.
Comment 15 Alex Dellapenta 2015-11-16 08:18:28 EST
(In reply to Alex Dellapenta from comment #14)
> This BZ was meant to cover the improvements to the installation utility
> (atomic-openshift-utils, f/k/a oo-install)

^ I meant to say atomic-openshift-installer here (atomic-openshift-utils being the package that provides the command).
Comment 16 Ma xiaoqiang 2015-11-16 19:32:27 EST
Now gpei is focus on testing the installation utility(atomic-openshift-utils). maybe he can help to review the doc. thx
Comment 17 Alex Dellapenta 2015-11-16 20:41:19 EST
@gei, setting you to QA content per Xiaoqiang's comment 16. Please let me know if you're able to review these docs on atomic-openshift-installer for OSE 3.1:

https://docs.openshift.com/enterprise/3.1/install_config/install/quick_install.html

Thanks!
Comment 18 Gaoyun Pei 2015-11-17 00:35:37 EST
Hi Alex,

I checked the doc, most contents look ok for me. 
One thing I'm not sure about is the "containerized: true" in https://docs.openshift.com/enterprise/3.1/install_config/install/quick_install.html#defining-an-installation-configuration-file 
"Example 1. Installation Configuration File Specification"

Since we never test with this configuration before, and not sure whether this option will be supported in OSE-3.1 release.
Comment 19 Alex Dellapenta 2015-11-17 00:38:24 EST
Thanks for reviewing. The callout description for that field says "Containerized installations are in Technology Preview in OpenShift Enterprise 3.1" and it is mentioned in the Release Notes as being in Technology Preview, so it is OK to mention here for OSE 3.1.
Comment 20 Alex Dellapenta 2015-11-17 00:47:28 EST
See comment 19. Is that acceptable?
Comment 21 Gaoyun Pei 2015-11-17 00:57:32 EST
Okay, thanks.
Move this bug to VERIFIED according to https://bugzilla.redhat.com/show_bug.cgi?id=1270618#c19
Comment 22 Alex Dellapenta 2015-11-17 00:58:27 EST
Cool, thank you!
Comment 23 Alex Dellapenta 2015-11-19 13:16:54 EST
Published in the following topic, which was updated per the new atomic-openshift-installer tool:

https://docs.openshift.com/enterprise/latest/install_config/install/quick_install.html

Note You need to log in before you can comment on or make changes to this bug.