Bug 1270657 - [abrt] WARNING: CPU: 3 PID: 0 at drivers/net/wireless/iwlwifi/pcie/trans.c:1444 iwl_trans_pcie_grab_nic_access+0x398/0x4a0 [iwlwifi]() [iwlwifi]
[abrt] WARNING: CPU: 3 PID: 0 at drivers/net/wireless/iwlwifi/pcie/trans.c:14...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:f989d49af60e56f320de5f9a503...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 00:59 EDT by Dan Loomis
Modified: 2016-09-24 23:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-24 23:47:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (162.06 KB, text/plain)
2015-10-12 00:59 EDT, Dan Loomis
no flags Details

  None (edit)
Description Dan Loomis 2015-10-12 00:59:24 EDT
Description of problem:
Watching a video on youtube.   Video window went black with "An error has occured" and wifi connectivity was dead.  

Additional info:
reporter:       libreport-2.6.2
WARNING: CPU: 3 PID: 0 at drivers/net/wireless/iwlwifi/pcie/trans.c:1444 iwl_trans_pcie_grab_nic_access+0x398/0x4a0 [iwlwifi]()
Timeout waiting for hardware access (CSR_GP_CNTRL 0xffffffff)
Modules linked in: rfcomm fuse xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun ccm nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_filter ebtable_broute bridge stp llc ebtable_nat ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_raw ip6table_security ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_raw iptable_security bnep hid_logitech_hidpp iTCO_wdt hp_wmi sparse_keymap iTCO_vendor_support ppdev arc4 intel_rapl iosf_mbi x86_pkg_temp_thermal coretemp kvm crct10dif_pclmul crc32_pclmul crc32c_intel ghash_clmulni_intel iwlmvm mac80211 joydev hid_logitech_dj uas uvcvideo iwlwifi videobuf2_vmalloc rtsx_pci_ms
 videobuf2_core videobuf2_memops v4l2_common usb_storage videodev memstick snd_hda_codec_realtek btusb btrtl media cfg80211 snd_hda_codec_generic btbcm btintel snd_hda_codec_hdmi bluetooth tpm_infineon snd_hda_intel snd_seq snd_hda_codec rfkill snd_seq_device snd_hda_core snd_hwdep snd_pcm snd_timer snd mei_me ie31200_edac mei edac_core lpc_ich i2c_i801 soundcore shpchp wmi parport_pc parport hp_accel tpm_tis lis3lv02d video input_polldev tpm hp_wireless nfsd auth_rpcgss nfs_acl lockd grace sunrpc rtsx_pci_sdmmc mmc_core amdkfd amd_iommu_v2 radeon serio_raw i2c_algo_bit drm_kms_helper ttm rtsx_pci drm e1000e ptp pps_core
CPU: 3 PID: 0 Comm: swapper/3 Not tainted 4.2.3-300.fc23.x86_64+debug #1
Hardware name: Hewlett-Packard HP ZBook 17 G2/2255, BIOS M70 Ver. 01.08 03/16/2015
 0000000000000000 58fb4a5bd9876fef ffff88048cc03be8 ffffffff81868ce6
 0000000000000000 ffff88048cc03c40 ffff88048cc03c28 ffffffff810ac446
 ffff88048a6e5480 ffff880486908000 0000000000000000 00000000ffffffff
Call Trace:
 <IRQ>  [<ffffffff81868ce6>] dump_stack+0x4c/0x65
 [<ffffffff810ac446>] warn_slowpath_common+0x86/0xc0
 [<ffffffff810ac4d5>] warn_slowpath_fmt+0x55/0x70
 [<ffffffffa0776188>] iwl_trans_pcie_grab_nic_access+0x398/0x4a0 [iwlwifi]
 [<ffffffffa0778f00>] iwl_trans_pcie_read_mem+0x40/0x440 [iwlwifi]
 [<ffffffffa076e4b3>] iwl_pcie_txq_stuck_timer+0xd3/0x390 [iwlwifi]
 [<ffffffff81134045>] ? call_timer_fn+0x5/0x490
 [<ffffffff81026cd8>] ? native_sched_clock+0x28/0x90
 [<ffffffffa076e3e0>] ? iwl_pcie_txq_unmap+0xf0/0xf0 [iwlwifi]
 [<ffffffff81134103>] call_timer_fn+0xc3/0x490
 [<ffffffff81134045>] ? call_timer_fn+0x5/0x490
 [<ffffffffa076e3e0>] ? iwl_pcie_txq_unmap+0xf0/0xf0 [iwlwifi]
 [<ffffffff811346eb>] run_timer_softirq+0x21b/0x440
 [<ffffffff810b25ee>] __do_softirq+0xde/0x630
 [<ffffffff810b2d8a>] irq_exit+0x11a/0x120
 [<ffffffff818757b6>] smp_apic_timer_interrupt+0x46/0x60
 [<ffffffff81873710>] apic_timer_interrupt+0x70/0x80
 <EOI>  [<ffffffff816d5004>] ? cpuidle_enter_state+0x134/0x3d0
 [<ffffffff816d4ffd>] ? cpuidle_enter_state+0x12d/0x3d0
 [<ffffffff816d52d7>] cpuidle_enter+0x17/0x20
 [<ffffffff810fc2c2>] call_cpuidle+0x32/0x60
 [<ffffffff816d52b3>] ? cpuidle_select+0x13/0x20
 [<ffffffff810fc5aa>] cpu_startup_entry+0x2ba/0x4c0
 [<ffffffff81058322>] start_secondary+0x192/0x1d0

Potential duplicate: bug 1236495
Comment 1 Dan Loomis 2015-10-12 00:59:33 EDT
Created attachment 1081860 [details]
File: dmesg
Comment 2 Dan Loomis 2015-11-24 21:39:28 EST
Description of problem:
Was browsing the web in Firefox and lost the wifi connection.   The Wifi symbol showed a question mark.   Turning the wifi off and back on was ineffective.   Problem similar to a bug reported in Fedora 22.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.6.3
cmdline:        BOOT_IMAGE=/vmlinuz-4.2.3-300.fc23.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet LANG=en_US.UTF-8
kernel:         4.2.3-300.fc23.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 2 PID: 0 at drivers/net/wireless/iwlwifi/pcie/trans.c:1444 iwl_trans_pcie_grab_nic_access+0x117/0x120 [iwlwifi]()
Timeout waiting for hardware access (CSR_GP_CNTRL 0xffffffff)
Modules linked in: ccm rfcomm fuse cmac xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_broute bridge stp llc ebtable_filter ebtable_nat ebtables ip6table_security ip6table_raw ip6table_mangle ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_filter ip6_tables iptable_security iptable_raw iptable_mangle iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack bnep arc4 hp_wmi iTCO_wdt tpm_infineon ppdev sparse_keymap iTCO_vendor_support intel_rapl iosf_mbi x86_pkg_temp_thermal coretemp iwlmvm snd_hda_codec_realtek kvm snd_hda_codec_generic mac80211 snd_hda_codec_hdmi snd_hda_intel snd_hda_codec crct10dif_pclmul crc32_pclmul uvcvideo snd_hda_core
 crc32c_intel btusb videobuf2_vmalloc videobuf2_core ghash_clmulni_intel btrtl btbcm snd_hwdep videobuf2_memops iwlwifi btintel v4l2_common snd_seq bluetooth videodev snd_seq_device rtsx_pci_ms cfg80211 memstick joydev snd_pcm snd_timer mei_me snd parport_pc i2c_i801 ie31200_edac media rfkill mei edac_core soundcore shpchp lpc_ich wmi parport hp_accel lis3lv02d input_polldev tpm_tis tpm hp_wireless nfsd auth_rpcgss nfs_acl lockd grace sunrpc amdkfd amd_iommu_v2 radeon rtsx_pci_sdmmc mmc_core i2c_algo_bit drm_kms_helper ttm e1000e drm serio_raw rtsx_pci ptp pps_core video
CPU: 2 PID: 0 Comm: swapper/2 Not tainted 4.2.3-300.fc23.x86_64 #1
Hardware name: Hewlett-Packard HP ZBook 17 G2/2255, BIOS M70 Ver. 01.07 02/26/2015
 0000000000000000 7aa5f17df0b52ac9 ffff88089dc83c78 ffffffff81771fca
 0000000000000000 ffff88089dc83cd0 ffff88089dc83cb8 ffffffff8109e4a6
 0000000000000000 ffff8808773f4000 0000000000000000 ffff8808773f7cb8
Call Trace:
 <IRQ>  [<ffffffff81771fca>] dump_stack+0x45/0x57
 [<ffffffff8109e4a6>] warn_slowpath_common+0x86/0xc0
 [<ffffffff8109e535>] warn_slowpath_fmt+0x55/0x70
 [<ffffffffa06a10a7>] iwl_trans_pcie_grab_nic_access+0x117/0x120 [iwlwifi]
 [<ffffffffa069ea5e>] iwl_trans_pcie_read_mem+0x3e/0xc0 [iwlwifi]
 [<ffffffffa069b27a>] iwl_pcie_txq_stuck_timer+0xca/0x380 [iwlwifi]
 [<ffffffffa069b1b0>] ? iwl_pcie_txq_unmap+0xf0/0xf0 [iwlwifi]
 [<ffffffff81105a19>] call_timer_fn+0x39/0xf0
 [<ffffffffa069b1b0>] ? iwl_pcie_txq_unmap+0xf0/0xf0 [iwlwifi]
 [<ffffffff8110604f>] run_timer_softirq+0x20f/0x2c0
 [<ffffffff810a285b>] __do_softirq+0xfb/0x290
 [<ffffffff810a2c09>] irq_exit+0x119/0x120
 [<ffffffff8177b6b6>] smp_apic_timer_interrupt+0x46/0x60
 [<ffffffff8177984b>] apic_timer_interrupt+0x6b/0x70
 <EOI>  [<ffffffff81108a4f>] ? hrtimer_start_range_ns+0x1bf/0x3b0
 [<ffffffff816160c0>] ? cpuidle_enter_state+0x130/0x270
 [<ffffffff8161609b>] ? cpuidle_enter_state+0x10b/0x270
 [<ffffffff81616237>] cpuidle_enter+0x17/0x20
 [<ffffffff810dfcc2>] call_cpuidle+0x32/0x60
 [<ffffffff81616213>] ? cpuidle_select+0x13/0x20
 [<ffffffff810dff58>] cpu_startup_entry+0x268/0x320
 [<ffffffff8104cca6>] start_secondary+0x186/0x1c0
Comment 3 Dan Loomis 2016-01-18 20:09:03 EST
Description of problem:
Had been on the web most all day.   Then poof, no more wifi.   Off and on had no effect.   Restarted system and back to normal.   I've seen this before but not awhile.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.6.3
cmdline:        BOOT_IMAGE=/vmlinuz-4.3.3-300.fc23.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet LANG=en_US.UTF-8
kernel:         4.3.3-300.fc23.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 6 PID: 0 at drivers/net/wireless/iwlwifi/pcie/trans.c:1543 iwl_trans_pcie_grab_nic_access+0x10f/0x120 [iwlwifi]()
Timeout waiting for hardware access (CSR_GP_CNTRL 0xffffffff)
Modules linked in: rfcomm fuse ccm cmac xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_nat ebtable_broute bridge stp llc ebtable_filter ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_raw ip6table_mangle ip6table_security ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_raw iptable_mangle iptable_security bnep arc4 intel_rapl tpm_infineon iosf_mbi iwlmvm x86_pkg_temp_thermal ppdev coretemp iTCO_wdt iTCO_vendor_support hp_wmi sparse_keymap kvm mac80211 crct10dif_pclmul crc32_pclmul crc32c_intel snd_hda_codec_realtek iwlwifi snd_hda_codec_generic snd_hda_codec_hdmi cfg80211 snd_hda_intel
 rtsx_pci_ms snd_hda_codec uvcvideo snd_hda_core i2c_i801 btusb memstick btrtl btbcm snd_hwdep btintel snd_seq bluetooth videobuf2_vmalloc videobuf2_core snd_seq_device joydev videobuf2_memops snd_pcm v4l2_common videodev snd_timer snd ie31200_edac mei_me parport_pc media rfkill mei soundcore shpchp lpc_ich edac_core parport wmi tpm_tis hp_accel lis3lv02d tpm video input_polldev hp_wireless nfsd auth_rpcgss nfs_acl lockd grace sunrpc uas usb_storage hid_logitech_hidpp amdkfd amd_iommu_v2 radeon rtsx_pci_sdmmc mmc_core i2c_algo_bit drm_kms_helper ttm e1000e drm serio_raw rtsx_pci ptp pps_core fjes hid_logitech_dj
CPU: 6 PID: 0 Comm: swapper/6 Not tainted 4.3.3-300.fc23.x86_64 #1
Hardware name: Hewlett-Packard HP ZBook 17 G2/2255, BIOS M70 Ver. 01.08 03/16/2015
 0000000000000000 d0231c5a78d543d0 ffff88049dd83cd0 ffffffff813a626f
 ffff88049dd83d18 ffff88049dd83d08 ffffffff810a07c2 ffff88048a25c000
 0000000000000000 ffff88048a25f5f8 ffff88049dd83db8 0000000000000000
Call Trace:
 <IRQ>  [<ffffffff813a626f>] dump_stack+0x44/0x55
 [<ffffffff810a07c2>] warn_slowpath_common+0x82/0xc0
 [<ffffffff810a085c>] warn_slowpath_fmt+0x5c/0x80
 [<ffffffffa073e83f>] iwl_trans_pcie_grab_nic_access+0x10f/0x120 [iwlwifi]
 [<ffffffffa073bd2e>] iwl_trans_pcie_read_mem+0x3e/0xc0 [iwlwifi]
 [<ffffffffa0737e5a>] iwl_pcie_txq_stuck_timer+0xca/0x380 [iwlwifi]
 [<ffffffffa0737d90>] ? iwl_pcie_txq_unmap+0xf0/0xf0 [iwlwifi]
 [<ffffffff811084a5>] call_timer_fn+0x35/0xf0
 [<ffffffffa0737d90>] ? iwl_pcie_txq_unmap+0xf0/0xf0 [iwlwifi]
 [<ffffffff81108aaf>] run_timer_softirq+0x20f/0x2c0
 [<ffffffff810a510b>] __do_softirq+0xfb/0x290
 [<ffffffff810a54a5>] irq_exit+0x105/0x110
 [<ffffffff817845d2>] smp_apic_timer_interrupt+0x42/0x50
 [<ffffffff81782437>] apic_timer_interrupt+0x87/0x90
 <EOI>  [<ffffffff8161f9c0>] ? cpuidle_enter_state+0x130/0x270
 [<ffffffff8161f99b>] ? cpuidle_enter_state+0x10b/0x270
 [<ffffffff8161fb37>] cpuidle_enter+0x17/0x20
 [<ffffffff810e26b2>] call_cpuidle+0x32/0x60
 [<ffffffff8161fb13>] ? cpuidle_select+0x13/0x20
 [<ffffffff810e2946>] cpu_startup_entry+0x266/0x320
 [<ffffffff8104d547>] start_secondary+0x157/0x190
Comment 4 Laura Abbott 2016-09-23 15:27:13 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 5 Dan Loomis 2016-09-24 23:47:41 EDT
Have not seen this problem recur since a full install of Fedora 24 on June 25, 2016

Note You need to log in before you can comment on or make changes to this bug.