Bug 127069 - clock applet does not use correct first day of the week
clock applet does not use correct first day of the week
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-01 10:35 EDT by Jarkko
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-15 16:25:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarkko 2004-07-01 10:35:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
The clock applet does not use correct first day of the week. It should
check LC_TIME environment variable if it is set. I think currently it
checks only LC_ALL and LANG. I tested with LC_ALL="fi_FI@euro" and it
worked. With LC_TIME="fi_FI@euro" it did not work.

Also it does not handle all locales correctly. Currently I have
LC_TIME="en_GB@euro" (LANG="en_GB@euro" too) and the clock shows
Sunday as the first day of the week. The first day of the week should
be Monday when using the locale "en_GB@euro".

Version-Release number of selected component (if applicable):
Clock 2.6.0

How reproducible:
Always

Steps to Reproduce:
1. Set LC_TIME to some locale that has Monday as first day of the week
2. Start Gnome session
3. Check the clock applet
    

Actual Results:  With LC_TIME="en_GB@euro" or "fi_FI@euro" the clock
shows Sunday as the first day of the week.

Expected Results:  It should show Monday as the first day of the week
when LC_TIME is set so.

Additional info:

So the problem is...

a) The clock applet does not check LC_TIME at all.
b) With en_GB locale the clock applet shows Sunday as first day of the
week instead of Monday.
Comment 1 Mark McLoughlin 2004-08-11 04:52:35 EDT
Moving to gtk2, but en_GB.po clearly has Sunday marked as the first
day of the week.
Comment 2 Matthias Clasen 2004-09-15 16:25:32 EDT
gtk uses a message to determine the first-day-of-week, therefore you
have to use LC_MESSAGES=en_GB@euro for gtkcalendar to pick the
first-day-of-week from the British locale.

Note You need to log in before you can comment on or make changes to this bug.