Bug 1270756 - Updating to RHEL 6.7, getting messages as: "Tried to move PID 26090, but 4 pages would not move"
Updating to RHEL 6.7, getting messages as: "Tried to move PID 26090, but 4 pa...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: numad (Show other bugs)
6.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Bill Gray
qe-baseos-daemons
:
Depends On:
Blocks: 1269194
  Show dependency treegraph
 
Reported: 2015-10-12 06:13 EDT by Gajanan
Modified: 2017-05-31 18:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-31 18:47:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1987103 None None None Never

  None (edit)
Description Gajanan 2015-10-12 06:13:18 EDT
Description of problem:

After Updating to RHEL 6.7, getting messages as: "Tried to move PID 26090, but 4 pages would not move". 

Customer have numad on our KVM hypervisors (total number of servers: 4). Since updating to RHEL 6.7 they are getting the following error messages in /var/log/numad.log:

~~~
Thu Oct  8 07:00:14 2015: Advising pid 26090 (qemu-kvm) move from nodes (0) to nodes (1)
Thu Oct  8 07:00:14 2015: Bad sched_setaffinity() on PID 26090, TID 26090 -- errno: 22
Thu Oct  8 07:00:14 2015: Bad sched_setaffinity() on PID 26090, TID 26120 -- errno: 22
Thu Oct  8 07:00:14 2015: Bad sched_setaffinity() on PID 26090, TID 9529 -- errno: 22
Thu Oct  8 07:00:15 2015: Tried to move PID 26090, but 4 pages would not move.
Thu Oct  8 07:00:15 2015: PID 26090 moved to node(s) 1 in 1.22 seconds
Thu Oct  8 07:01:05 2015: Advising pid 26090 (qemu-kvm) move from nodes (1) to nodes (0)
~~~

Why these errors are caused ? Is there any thing to worry about these messages ?  

- Customer mentioned, they are not facing any issues and just recognizing these error messages since updating to RHEL 6.7. 

- The error appears round about every 5 minutes or 10 or 15 minutes. 

~~~
Mon Oct 12 00:00:24 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 00:45:14 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 01:00:14 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 01:00:21 2015: Tried to move PID 14587, but 4 pages would not move.
Mon Oct 12 01:30:16 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 02:00:15 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 02:01:53 2015: Tried to move PID 14587, but 4 pages would not move.
Mon Oct 12 02:04:21 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 02:15:21 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 02:57:00 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 03:00:28 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 03:01:48 2015: Tried to move PID 14587, but 4 pages would not move.
Mon Oct 12 03:05:17 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 04:00:15 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 04:05:47 2015: Tried to move PID 13571, but 4 pages would not move.
Mon Oct 12 04:55:21 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 05:00:20 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 05:25:19 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 05:35:17 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 06:05:20 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 06:06:47 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 06:45:21 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 06:55:20 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 07:00:18 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 07:00:39 2015: Tried to move PID 26090, but 12 pages would not move.
Mon Oct 12 07:05:16 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 07:15:15 2015: Tried to move PID 26090, but 4 pages would not move.
Mon Oct 12 07:25:14 2015: Tried to move PID 26090, but 4 pages would not move.
~~~
Comment 4 Chris Williams 2017-05-31 18:47:51 EDT
Red Hat Enterprise Linux 6 transitioned to the Production 3 Phase on May 10, 2017.  During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not appear to meet the inclusion criteria for the Production Phase 3 and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification.  Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com

Note You need to log in before you can comment on or make changes to this bug.