Bug 1270774 - Can't open files on samba share
Can't open files on samba share
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: dolphin (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: KDE SIG
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 07:23 EDT by j.gjorgji
Modified: 2016-07-19 14:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 14:11:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description j.gjorgji 2015-10-12 07:23:14 EDT
Description of problem:
I've mounted the share with the same username and password with other file managers and it worked fine, gvfs-smb seems to be working fine and so does Windows 7. I've tried doing it from the livecd in case my system is messed up but i ended up with the same result.

Opening a text file with gVim seemed to work fine, i didn't try other programs.

Version-Release number of selected component (if applicable):
dolphin.x86_64                        15.04.2-1.fc22

How reproducible:
Always

Steps to Reproduce:
1. Mount samba share
2. Open any file with a KDE/Qt application

Actual results:
Access denied error

Expected results:
Opens file normally

Additional info:
I filed this under dolphin because i don't know where's the proper place.
Comment 3 David Tonhofer 2015-11-19 05:58:41 EST
Got this problem now after a network IP address relabeling (formerly 192.168.178.0/24, now 192.168.10.0/24).

Opening an SMB share on an SMB server via Dolphin (dolphin-15.04.3-2.fc22.x86_64) results in "Access denied", no questions even asked.

- The share is password-protected
- The SMB resources on the network cannot be listed in Dolphin, one has to access the share by putting in the path in the "path-to-resource bar" 
- Listing the shares available of the SMB server works via explicit indication of path works
- Credentials for the share (using the IP address prior to relabeling) were in KDE wallet; I removed them using kwalletmanager for good measure but that didn't change anything
- Accessing the share from the command line via smbclient works nicely:

-----
$ smbclient //192.168.10.2/SCAN -U "Bastard Operator From Hell" 
Enter Bastard Operator From Hell's password: 
Domain=[FOODOMAIN] OS=[Unix] Server=[Samba 4.1.18]
smb: \> dir
  .                                  DA        0  Thu Nov 19 11:21:43 2015
  ..                                 DA        0  Thu Nov  5 12:07:21 2015
  .DS_Store                          AH     8196  Wed Nov 11 11:53:28 2015
  .TemporaryItems                   DAH        0  Mon Mar 23 09:42:13 2015
  BrotherScan_008939.pdf              A   387724  Wed Nov 18 22:48:12 2015
  Thumbs.db                          HS    18432  Wed Nov 18 22:57:00 2015
  BrotherScan_008947.pdf              A   774420  Thu Nov 19 10:59:06 2015

                2879621632 blocks of size 1024. 2400457232 blocks available
-----

Is there any way to get verbose debug infor from Dolphin?
Comment 4 Fedora End Of Life 2016-07-19 14:11:25 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.