Bug 1270780 - Add Affinity Rules Enforcement Manager interval to engine-config
Add Affinity Rules Enforcement Manager interval to engine-config
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-3.6.2
: 3.6.2.5
Assigned To: Tomer Saban
Artyom
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 07:31 EDT by Tomer Saban
Modified: 2016-02-18 06:15 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:15:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dfediuck: ovirt‑3.6.z?
rule-engine: planning_ack?
dfediuck: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47219 master MERGED core: Added ability to change AREM interval to engine-config Never
oVirt gerrit 50952 ovirt-engine-3.6 MERGED core: Added ability to change AREM interval to engine-config 2015-12-23 04:10 EST
oVirt gerrit 51077 master MERGED core: Fixed Affinity Rules Enforcer task scheduling 2015-12-27 05:21 EST
oVirt gerrit 51078 ovirt-engine-3.6.2 MERGED core: Added ability to change AREM interval to engine-config 2015-12-28 09:01 EST
oVirt gerrit 51079 ovirt-engine-3.6.2 MERGED core: Fixed Affinity Rules Enforcer task scheduling 2015-12-28 09:01 EST
oVirt gerrit 51080 ovirt-engine-3.6 MERGED core: Fixed Affinity Rules Enforcer task scheduling 2015-12-27 08:47 EST

  None (edit)
Description Tomer Saban 2015-10-12 07:31:08 EDT
Description of problem:
Datacenter admin can't change the interval of Affinity Rules Enforcement Manager.

Steps to Reproduce:
1. Change interval of AREM using engine-config to 5 minutes
2. Run engine (Using share/ovirt-engine/services/ovirt-engine/ovirt-engine.py start)

Expected results:
1. AREM will run after 5 minutes instead of 1.
Comment 1 Yaniv Lavi 2015-10-29 08:41:02 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 2 Doron Fediuck 2015-10-29 09:29:31 EDT
Please explain which config key should be used and what AREM is.
Comment 3 Tomer Saban 2015-10-29 11:11:57 EDT
config key that should be used: AffinityRulesEnforcementManagerRegularInterval
can be changed to 5 minutes by typing in the shell from the root directory of oVirt:
bin/engine-config -s AffinityRulesEnforcementManagerRegularInterval=5

AREM, as stated in the "description of problem" stands for Affinity Rules Enforcement Manager. It is a manager which is responsible for enforcing VM affinity.
Comment 4 Sandro Bonazzola 2015-12-23 10:08:22 EST
This bug has target milestone 3.6.2 and is on modified without a target release.
This may be perfectly correct, but please check if the patch fixing this bug is included in ovirt-engine-3.6.2. If it's included, please set target-release to 3.6.2 and move to ON_QA. Thanks.
Comment 5 Tomer Saban 2015-12-27 05:19:23 EST
Added some patches. This should stay in POST until all bugs will be merged.
Comment 6 Red Hat Bugzilla Rules Engine 2015-12-27 05:21:19 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 7 Tomer Saban 2016-01-13 04:44:24 EST
Why did you remove me from the bug?
Comment 8 Sandro Bonazzola 2016-01-19 11:11:33 EST
(In reply to Tomer Saban from comment #7)
> Why did you remove me from the bug?

Sorry, unwanted change while mass moving target to  3.6.2.5
Comment 9 Artyom 2016-01-21 06:54:48 EST
Checked on rhevm-backend-3.6.2.5-0.1.el6.noarch
[root@alukiano-rhevm-36 ~]# engine-config -g AffinityRulesEnforcementManagerRegularInterval
AffinityRulesEnforcementManagerRegularInterval: 1 version: general
[root@alukiano-rhevm-36 ~]# engine-config -s AffinityRulesEnforcementManagerRegularInterval=5
[root@alukiano-rhevm-36 ~]# engine-config -g AffinityRulesEnforcementManagerRegularInterval
AffinityRulesEnforcementManagerRegularInterval: 5 version: general


I see that engine not apply correct interval on first AREM run.
016-01-21 11:29:37,153 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ServerService Thread Pool -- 50) [] Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: Affinity Rules Enforcement Manager started.

2016-01-21 11:30:37,156 DEBUG [org.ovirt.engine.core.bll.scheduling.AffinityRulesEnforcementManager] (DefaultQuartzScheduler_Worker-26) [] Affinity Rules Enforcement Manager interval reached.

2016-01-21 11:35:37,808 DEBUG [org.ovirt.engine.core.bll.scheduling.AffinityRulesEnforcementManager] (DefaultQuartzScheduler_Worker-57) [] Affinity Rules Enforcement Manager interval reached.

2016-01-21 11:40:37,835 DEBUG [org.ovirt.engine.core.bll.scheduling.AffinityRulesEnforcementManager] (DefaultQuartzScheduler_Worker-64) [] Affinity Rules Enforcement Manager interval reached.

I do not think it is some serous problem with that, but Tomer can you approve that it is desired behavior?
Comment 10 Tomer Saban 2016-01-24 03:27:05 EST
That's OK. That's the desired behaviour. The initial message is for the initialization of the Affinity Rules Enforcement Manager and then, we want the it start the regular process regardless of the interval. So it will commence after 1 minute of the initialization.
Comment 11 Artyom 2016-01-24 09:38:54 EST
Verified on rhevm-backend-3.6.2.5-0.1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.