Bug 1270826 - [webadmin] Not able to configure local storage on host
[webadmin] Not able to configure local storage on host
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity urgent (vote)
: ovirt-3.6.0-rc3
: 3.6.0.3
Assigned To: Tal Nisan
Kevin Alon Goldblatt
storage
: Regression
: 1218534 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 09:18 EDT by Gonza
Modified: 2016-02-10 12:13 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-27 02:53:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
ylavi: blocker-
ylavi: planning_ack+
tnisan: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
javascript error (4.05 KB, text/plain)
2015-10-12 09:18 EDT, Gonza
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47451 master MERGED webadmin: Configure local storage does not work Never
oVirt gerrit 47455 ovirt-engine-3.6 MERGED webadmin: Configure local storage does not work Never
oVirt gerrit 47459 ovirt-engine-3.6.0 MERGED webadmin: Configure local storage does not work Never

  None (edit)
Description Gonza 2015-10-12 09:18:25 EDT
Created attachment 1082015 [details]
javascript error

Description of problem:
When trying to configure a local storage on a host (which is already in maintenance) a javascript error is generated by either clicking on the OK button or pressing enter. Verified on Chrome and Firefox.

Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.18.el6.noarch
firefox-40.0.3-1.fc22.x86_64
google-chrome-stable-41.0.2272.101-1.x86_64

How reproducible:
100 %

Steps to Reproduce:
1. Access a host terminal and create a folder which will be used as the local storage directory
2. chown 36:36 {local_storage_dir}
3. chmod 755 {local_storage_dir}
4. Set the host to maintenance mode from webadmin (if not already on it)
5. Click on the "Configure Local Storage" button
6. Input {local_storage_dir} under the "Set the path to your local storage:" field
7. Click OK or press Enter

Actual results:
Nothing is displayed and the "Configure local storage" window remains on display. Javascript Exception is raised.

Expected results:
Local storage is configured successfully.

Additional info:
JavaScript error msg attached.
Comment 1 Einav Cohen 2015-10-14 02:58:45 EDT
looks like an application-level NPE on the client side (GWT-compiling the code in non-obfuscated mode and reproducing the problem should reveal the exact cause).
Comment 2 Allon Mureinik 2015-10-14 03:58:25 EDT
Tal - let's assign someone to this please?
Comment 3 Tal Nisan 2015-10-19 06:38:51 EDT
*** Bug 1218534 has been marked as a duplicate of this bug. ***
Comment 4 Red Hat Bugzilla Rules Engine 2015-10-19 06:51:06 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 5 Red Hat Bugzilla Rules Engine 2015-10-22 09:18:40 EDT
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 6 Red Hat Bugzilla Rules Engine 2015-10-22 09:18:40 EDT
Fixed bug tickets must have target milestone set prior to fixing them. Please set the correct milestone and move the bugs back to the previous status after this is corrected.
Comment 7 Red Hat Bugzilla Rules Engine 2015-10-22 09:18:40 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 8 Red Hat Bugzilla Rules Engine 2015-10-22 09:19:45 EDT
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 9 Red Hat Bugzilla Rules Engine 2015-10-22 09:19:45 EDT
Fixed bug tickets must have target milestone set prior to fixing them. Please set the correct milestone and move the bugs back to the previous status after this is corrected.
Comment 10 Red Hat Bugzilla Rules Engine 2015-10-22 09:19:45 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 11 Kevin Alon Goldblatt 2015-10-26 15:27:36 EDT
Code used to check:
----------------------------
rhevm-3.6.0-0.18.el6.noarch
vdsm-4.17.8-1.el7ev.noarch

Used the following Steps to Reproduce:
1. Access a host terminal and create a folder which will be used as the local storage directory
2. chown 36:36 {local_storage_dir}
3. chmod 755 {local_storage_dir}
4. Set the host to maintenance mode from webadmin (if not already on it)
5. Click on the "Configure Local Storage" button
6. Input {local_storage_dir} under the "Set the path to your local storage:" field
7. Click OK or press Enter

Actual results:
Nothing is displayed and the "Configure local storage" window remains on display. Javascript Exception is raised.

Expected results:
Local storage is configured successfully.

The problem still exists. Moving to ASSIGNED
Comment 12 Red Hat Bugzilla Rules Engine 2015-10-26 18:55:05 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 13 Tal Nisan 2015-10-29 09:31:23 EDT
This build is cut off from 8c54d39a2fd018cd3e69f807401c5d896ff24cc1 and indeed does not contain the fix, it should be on the GA build, moving to ON_QA and setting the target correctly
Comment 14 Yaniv Lavi 2015-10-29 09:33:48 EDT
(In reply to Tal Nisan from comment #13)
> This build is cut off from 8c54d39a2fd018cd3e69f807401c5d896ff24cc1 and
> indeed does not contain the fix, it should be on the GA build, moving to
> ON_QA and setting the target correctly

You mean in the latest RC3?
Comment 15 Tal Nisan 2015-11-01 06:19:09 EST
Yes
Comment 16 Red Hat Bugzilla Rules Engine 2015-11-02 07:26:45 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 17 Red Hat Bugzilla Rules Engine 2015-11-16 04:57:31 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 18 Kevin Alon Goldblatt 2015-11-19 10:12:15 EST
Code used to check:
----------------------------
rhevm-3.6.0.3-0.1.el6.noarch
vdsm-4.17.10.1-0.el7ev.noarch

Used the following Steps to Reproduce:
1. Access a host terminal and create a folder which will be used as the local storage directory
2. chown 36:36 {local_storage_dir}
3. chmod 755 {local_storage_dir}
4. Set the host to maintenance mode from webadmin (if not already on it)
5. Click on the "Configure Local Storage" button
6. Input {local_storage_dir} under the "Set the path to your local storage:" field
7. Click OK or press Enter

Actual results:
Local storage is configured successfully

Moving to VERIFIED!
Comment 19 Sandro Bonazzola 2015-11-27 02:53:36 EST
Since oVirt 3.6.0 has been released, moving from verified to closed current release.

Note You need to log in before you can comment on or make changes to this bug.