Bug 1270834 - Remove network disk or direct lun times out
Remove network disk or direct lun times out
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
4.17.11
Unspecified Unspecified
high Severity urgent (vote)
: ovirt-3.5.6
: 4.16.29
Assigned To: Amit Aviram
Aharon Canan
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-12 09:30 EDT by Ori Gofen
Modified: 2016-02-10 14:21 EST (History)
12 users (show)

See Also:
Fixed In Version: v4.16.29
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 08:24:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.5.z+
rule-engine: blocker+
ylavi: planning_ack+
tnisan: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)
log (5.28 MB, text/plain)
2015-10-12 09:30 EDT, Ori Gofen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47795 master MERGED hotunplug: Supporting lun and cinder disks fix. Never
oVirt gerrit 47846 ovirt-3.6 MERGED hotunplug: Supporting lun and cinder disks fix. Never
oVirt gerrit 47926 ovirt-3.5 MERGED hotunplug: Supporting lun disks fix. Never

  None (edit)
Description Ori Gofen 2015-10-12 09:30:28 EDT
Created attachment 1082020 [details]
log

Description of problem:
HotUnplug of a cinder disk fails

Version-Release number of selected component (if applicable):
rhevm-3.6-14

How reproducible:
100%

Steps to Reproduce:
1.Have a VM+cinder disk
2.install OS!!!
3.attempt to deactivate the disk while VM is up

Actual results:
operation fails

Expected results:
operation successful

Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:56:50 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Daniel Erez 2015-10-25 04:54:27 EDT
Hi Ori,

A couple of questions to investigate the issue:
* With which disk interface has the Cinder disk been attached?
* Which OS was installed?
* Which libvirt/qemu versions?
* Can you please attach the relevant VDSM log as well
Comment 3 Daniel Erez 2015-10-26 07:52:03 EDT
After discussing with Amit, it seems that the hot-unplug timeout indication is based on the serial xml element: https://gerrit.ovirt.org/#/c/45138/19/vdsm/virt/vm.py (line 2663). However, 'serial' element is missing on Cinder and LUN disks.
@Nir - how do you suggest to tackle this issue? Should we have a unique ID be each disk or perhaps have some another technique to identify unplugged disk.
Comment 4 Nir Soffer 2015-10-26 08:20:52 EDT
(In reply to Daniel Erez from comment #3)
> After discussing with Amit, it seems that the hot-unplug timeout indication
> is based on the serial xml element:
> https://gerrit.ovirt.org/#/c/45138/19/vdsm/virt/vm.py (line 2663). However,
> 'serial' element is missing on Cinder and LUN disks.
> @Nir - how do you suggest to tackle this issue? Should we have a unique ID
> be each disk

Yes, why don't we set the serial element?

We should use the same way for any kind of disk.
Comment 5 Ori Gofen 2015-10-26 11:30:33 EDT
It seems this bug is not related directly to Cinder implementation since it is reproducing with Dlun disks, this case was passing storage automation and now it fails, thus marking it, Regression :))
Comment 6 Red Hat Bugzilla Rules Engine 2015-10-26 13:21:11 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 7 Red Hat Bugzilla Rules Engine 2015-10-26 13:21:11 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 8 Maor 2015-10-26 18:05:27 EDT
removing blocker of https://bugzilla.redhat.com/1270834, since this appears to be a general issue
Comment 9 Ori Gofen 2015-10-27 05:50:37 EDT
yes it is not blocking bz #1135132, sorry for yelling
Comment 10 Nir Soffer 2015-10-27 15:48:48 EDT
First, the fact that direct lun does not have a serial does not explain
the hot unplug failure - I would expect that the operation will always succeed, because when we check if the disk exists, we will never find it 
(there is no disk with empty serial).

Second, you cannot detach the disk the vm was booted from - this will not
work for any type of disk, and is not a bug.

It seems that the description for this bug is incorrect, and the logs are
missing.

Ori, please attach vdsm logs showing the failure, as requested in comment 2.
Comment 11 Nir Soffer 2015-10-27 17:07:27 EDT
Correction, qemu does allow hot-unplugging the boot disk. After this, it
is not possible to connect to the vm console, it is busy looping, 
complaining about reeadonly file system.

This test should be performed on a second disk, not on the boot disk.
We should check with qemu/libvirt guys about allowing hot-unplugging of the boot disk, this does not look useful to any user.
Comment 13 Yaniv Lavi (Dary) 2015-11-01 06:54:28 EST
In oVirt testing is done on single release by default. Therefore I'm removing the 3.6 flag. If you think this bug must be tested in 3.6 as well, please re-add the flag. Please note we might not have testing resources to handle the 3.6 clone.
Comment 14 Red Hat Bugzilla Rules Engine 2015-11-05 04:05:42 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 15 Red Hat Bugzilla Rules Engine 2015-11-05 07:01:18 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 16 Red Hat Bugzilla Rules Engine 2015-11-05 07:13:57 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 17 Aharon Canan 2015-11-10 07:39:29 EST
Verified using vt18.2 (vdsm-4.16.29-1.el7ev.x86_64)

Verification steps:
===================
1. Have a VM and OS installed (Boot disk on Gluster domain)
2. Hotplug direct lun (over ISCSI)
3. HotUnPlug the direct lun

Actual results:
operation successful
Comment 18 Sandro Bonazzola 2015-12-22 08:24:44 EST
oVirt 3.5.6 has been released and the bz verified, moving to closed current release.

Note You need to log in before you can comment on or make changes to this bug.