Bug 1271138 - puppet module for manila should include service type - shareV2
Summary: puppet module for manila should include service type - shareV2
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RDO
Classification: Community
Component: openstack-puppet-modules
Version: Liberty
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
: Liberty
Assignee: Ivan Chavero
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-13 08:46 UTC by krishnaram Karthick
Modified: 2016-04-18 06:47 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1512577 0 None None None Never

Description krishnaram Karthick 2015-10-13 08:46:45 UTC
Description of problem:

All manila commands fail on systems installed with RDO (liberty RC-2 branch) using packstack. 

/usr/lib/python2.7/site-packages/manilaclient/shell.py sets DEFAULT_MANILA_SERVICE_TYPE = constants.V2_SERVICE_TYPE. However, all manila commands use V1 service type and code for V2 isn't available yet.

Version-Release number of selected component (if applicable):

# rpm -qa | grep 'manila'
python-manila-1.0.0.0-rc2.dev24.el7.centos.noarch
python-manilaclient-1.4.1-dev3.el7.centos.noarch
openstack-manila-1.0.0.0-rc2.dev24.el7.centos.noarch
openstack-manila-share-1.0.0.0-rc2.dev24.el7.centos.noarch


How reproducible:
Always

Steps to Reproduce:
1. Install latest RDO (liberty RC-2) using packstack. Edit answer file to have manila installed
2. Run any manila command
3.

Actual results:

# manila list
ERROR: Could not find Manila endpoint in catalog


Expected results:
No errors and available manila shares should be listed

Additional info:

Setting share type explicitly to 'share' helps in running the command successfully.

# manila --service-type share list
+----+------+------+-------------+--------+-----------+------------+-----------------+------+-------------------+
| ID | Name | Size | Share Proto | Status | Is Public | Share Type | Export location | Host | Availability Zone |
+----+------+------+-------------+--------+-----------+------------+-----------------+------+-------------------+
+----+------+------+-------------+--------+-----------+------------+-----------------+------+-------------------+

Comment 1 krishnaram Karthick 2015-10-13 11:25:13 UTC
Devstack uses V2 and keystone in devstack catalog shows up a service called 'shareV2'. This means the statement in my previous comment is incorrect. 

In order to have a working configuration with packstack, puppet modules have to be updated to configure shareV2 service and create keystone endpoints to use V2.

Changing the bug title from 'manila default service type is set to V2_SERVICE_TYPE, while only v1 service type code is available in python manila client' to 'puppet module for manila should include service type - shareV2'

Comment 2 Pete Zaitcev 2015-11-23 23:04:53 UTC
Reassigning to openstack-puppet-modules where someone could do
a meaningful triage to this bug.

Comment 3 Javier Peña 2015-12-16 17:03:33 UTC
The latest OPM rebase seems to have fixed it.

Comment 4 Sean Cohen 2016-01-24 21:23:22 UTC
(In reply to Javier Peña from comment #3)
> The latest OPM rebase seems to have fixed it.

Hi Karthick,
Can you test the fix and update/close the bug accordingly?
Thanks
Sean

Comment 5 Dustin Schoenbrun 2016-01-27 21:11:42 UTC
Tested with the latest development packages listed below:
openstack-packstack-puppet-7.0.0-dev1687.g4008f10.el7.centos.noarch
openstack-packstack-7.0.0-dev1687.g4008f10.el7.centos.noarch

Looks like we're able to use the Manila command as expected now.


Note You need to log in before you can comment on or make changes to this bug.