Bug 1271164 - Soft dependency is not installed for package specified via command line
Soft dependency is not installed for package specified via command line
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-13 05:52 EDT by Vít Ondruch
Modified: 2015-10-13 06:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 06:18:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
--debugsolver output (4.21 MB, application/x-gzip)
2015-10-13 05:52 EDT, Vít Ondruch
no flags Details

  None (edit)
Description Vít Ondruch 2015-10-13 05:52:50 EDT
Created attachment 1082317 [details]
--debugsolver output

Description of problem:
### Initialize build root
$ mock -r fedora-rawhide-x86_64 --init

### Install all dependencies
$ mock -r fedora-rawhide-x86_64 --install 'ruby(release)' 'ruby(rubygems)' 'rubygem(fog-libvirt)' 'rubygem(multi_json)' 'rubygem(nokogiri)' 'shadow-utils' 'rubygem(bundler)' 'rubygem(childprocess)' 'rubygem(hashicorp-checkpoint)' bsdtar 'rubygem(erubis)' 'rubygem(listen)' rubygem-http-cookie rubygem-i18n rubygem-log4r rubygem-net-http-persistent rubygem-net-sftp rubygem-rest-client rubygem-rb-inotify 


### Install vagrant scratch build, with Recommends: vagrant(vagrant-libvirt)

$ rpm -q -p --recommends https://kojipkgs.fedoraproject.org//work/tasks/3246/11423246/vagrant-1.7.4-2.fc24.noarch.rpm
vagrant(vagrant-libvirt)

$ sudo dnf repoquery --whatprovides 'vagrant(vagrant-libvirt)' 
Last metadata expiration check performed 1:09:13 ago on Tue Oct 13 10:36:30 2015.
vagrant-libvirt-0:0.0.31-1.fc24.noarch

$ sudo dnf --installroot /var/lib/mock/fedora-rawhide-x86_64/root/ --releasever 24 install https://kojipkgs.fedoraproject.org//work/tasks/3246/11423246/vagrant-1.7.4-2.fc24.noarch.rpm --setopt=tsflags=nocontexts --setopt=errorlevel=10 --setopt=debuglevel=10 --debugsolver
timer: config: 5 ms
cachedir: /var/lib/mock/fedora-rawhide-x86_64/root/var/cache/dnf
Loaded plugins: builddep, debuginfo-install, system-upgrade, noroot, generate_completion_cache, download, langpacks, copr, needs-restarting, config-manager, Query, reposync, playground, protected_packages
langpacks: No languages are enabled
initialized Langpacks plugin
DNF version: 1.1.2
Command: dnf 
Installroot: /var/lib/mock/fedora-rawhide-x86_64/root/
Releasever: 24
Base command: install
Extra commands: ['https://kojipkgs.fedoraproject.org//work/tasks/3246/11423246/vagrant-1.7.4-2.fc24.noarch.rpm']
repo: downloading from remote: fedora, _Handle: metalnk: https://mirrors.fedoraproject.org/metalink?repo=rawhide&arch=x86_64, mlist: None, urls [].
fedora                                                                                                                                                                              78 MB/s |  44 MB     00:00    
not found updateinfo for: fedora
timer: sack setup: 19825 ms
fedora: using metadata from Mon Oct 12 10:55:17 2015.
Last metadata expiration check performed 0:00:18 ago on Tue Oct 13 11:41:52 2015.
Completion plugin: Generating completion cache...
--> Starting dependency resolution
---> Package vagrant.noarch 1.7.4-2.fc24 will be installed
--> Finished dependency resolution
timer: depsolve: 2216 ms
Dependencies resolved.
langpacks: enabled languages are ['en']
===================================================================================================================================================================================================================
 Package                                               Arch                                         Version                                               Repository                                          Size
===================================================================================================================================================================================================================
Installing:
 vagrant                                               noarch                                       1.7.4-2.fc24                                          @commandline                                       443 k
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 vagrant-libvirt                                       noarch                                       0.0.31-1.fc24                                         fedora                                              65 k

Transaction Summary
===================================================================================================================================================================================================================
Install  1 Package

Total size: 443 k
Installed size: 1.5 M
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
timer: transaction test: 14 ms
Running transaction
RPM transaction start.
  Installing  : vagrant-1.7.4-2.fc24.noarch                                                                                                                                                                    1/1 
RPM transaction over.
  Verifying   : vagrant-1.7.4-2.fc24.noarch                                                                                                                                                                    1/1 
timer: verify transaction: 117 ms
timer: transaction: 660 ms

Installed:
  vagrant.noarch 1.7.4-2.fc24                                                                                                                                                                                      

Completion plugin: Generating completion cache...
Complete!
Cleaning up.





Version-Release number of selected component (if applicable):
$ rpm -q dnf
dnf-1.1.2-4.fc24.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
vagrant-libvirt is not installed.


Expected results:
vagrant-libvirt is installed.


Additional info:
See solver ouput in attachment.
Comment 1 Vít Ondruch 2015-10-13 06:18:01 EDT
This is apparently caused by:

$ cat /etc/mock/fedora-rawhide-x86_64.cfg | grep weak
install_weak_deps=0

Sorry for the noise :/

Note You need to log in before you can comment on or make changes to this bug.