Bug 1271177 - motif-devel conflicts with lesstif-devel
motif-devel conflicts with lesstif-devel
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: motif (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-13 06:40 EDT by Pavel Grunt
Modified: 2016-12-20 09:58 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 09:58:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Transaction check error (34.42 KB, text/plain)
2015-10-13 06:40 EDT, Pavel Grunt
no flags Details

  None (edit)
Description Pavel Grunt 2015-10-13 06:40:16 EDT
Created attachment 1082323 [details]
Transaction check error

Description of problem:
Installing motif-devel conflicts with lesstif-devel. Should motif-devel  obsolete lesstif ?

Version-Release number of selected component (if applicable):
motif-devel-2.3.4-10.fc23.x86_64

How reproducible:
100 %

Steps to Reproduce:
1. dnf install motif-devel

Actual results:
Transaction check error:
file /usr/include/Mrm/MrmAppl.h from install of motif-devel-2.3.4-10.fc23.x86_64 conflicts with file from package lesstif-devel-0.95.2-9.fc23.x86_64
and many others, see attachement

Expected results:
Install motif-devel

Additional info:
Hit the issue when trying to upgrade mesa-libGLw to 8.0.0-7.fc23
Comment 1 Thomas Woerner 2015-10-23 10:33:26 EDT
As far as I know there is some movement to drop Lesstif in favor of Motif in Fedora >= 24.

Motif has been relicensed under LGPLv2+ in 2012. There is no need for Lesstif as an OSS version anymore in my opinion, especially as it is not 100% compatible still to real Motif especially with bad code using internal only APIs.

I think that motif-devel should only obsolete lesstif-devel if there is no requirement for lesstif-devel anymore. This might be the case now and needs to be verified.
Comment 2 Pavel Grunt 2015-11-02 12:29:58 EST
(In reply to Thomas Woerner from comment #1)
> As far as I know there is some movement to drop Lesstif in favor of Motif in
> Fedora >= 24.
> 
> Motif has been relicensed under LGPLv2+ in 2012. There is no need for
> Lesstif as an OSS version anymore in my opinion, especially as it is not
> 100% compatible still to real Motif especially with bad code using internal
> only APIs.
> 
> I think that motif-devel should only obsolete lesstif-devel if there is no
> requirement for lesstif-devel anymore. This might be the case now and needs
> to be verified.

dnf repoquery --whatrequires lesstif-devel --alldeps

gives:
InventorXt-devel-0:2.1.5-53.fc23.i686
InventorXt-devel-0:2.1.5-53.fc23.x86_64
grass-devel-0:6.4.4-9.fc23.i686
grass-devel-0:6.4.4-9.fc23.x86_64
mesa-libGLw-devel-0:8.0.0-6.fc23.i686
mesa-libGLw-devel-0:8.0.0-6.fc23.x86_64

(mesa-libGLw-devel-0:8.0.0-7 requires motif-devel)
Comment 3 Thomas Woerner 2015-11-03 09:35:08 EST
All these pacakges will move to motif with Fedora 24. The changes are already done in rawhide.
Comment 4 Laurent G 2015-11-10 06:20:52 EST
The conflict between motif-devel and lesstif-devel block me in the upgrade from F22 to F23!

Here is a copy paste of the system-upgrade tentative with the error (partially in French, I can translate if needed)

> root@blue-lagoon:~# dnf system-upgrade download --releasever=23
> Vérification de l'expiration des métadonnées effectuée il y a 0:17:45 sur Tue Nov 10 11:58:28 2015.
> Dépendances résolues.
> ======================================================================================================================
>  Paquet                                    Architecture
>                                                   Version                             Dépôt                     Taille
> ======================================================================================================================
> Installation de :
>  GeoIP                                     x86_64 1.6.6-1.fc23                        fedora                    118 k
>  GeoIP-GeoLite-data                        noarch 2015.09-1.fc23                      fedora                    353 k
>  audit-libs-python3                        x86_64 2.4.4-2.fc23                        fedora                     96 k
[...SNIP...]
> Résumé de la transaction
> ======================================================================================================================
> Installation                     105 Packages
> Mettre à jour                   1928 Packages
> Supprimer                          5 Packages
> Retour à la version précédente    10 Packages
> 
> Taille totale  : 1.6 G
> Taille totale des téléchargements : 244 k
> Est-ce correct [o/N] : o
[...SNIP...]
> (2040/2040): libreoffice-core-5.0.3.2-4.fc23.x86_64.rpm                                                                           1.4 MB/s |  74 MB     00:51    
> -------------------------------------------------------------------------------------------------------------------------------------------------------------
> Total                                                                                                                             2.9 MB/s | 158 MB     00:54     
> Test de la transaction en cours
> La vérification de la transaction a réussi.
> Lancement de la transaction de test
> Les paquets téléchargés ont été enregistrés dans le cache jusqu'à la prochaine transaction réussie.
> You can remove cached packages by executing 'dnf clean packages'.
> Erreur : Erreur du contrôle de transaction
>   file /usr/include/Mrm/MrmAppl.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Mrm/MrmDecls.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Mrm/MrmPublic.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/AccTextT.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ActivatableT.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ArrowB.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ArrowBG.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ArrowBGP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ArrowBP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/AtomMgr.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/BaseClassP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/BulletinB.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/BulletinBP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/CacheP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/CareVisualT.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/CascadeB.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/CascadeBG.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/CascadeBGP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/CascadeBP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ColorObjP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ComboBox.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ComboBoxP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Command.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/CommandP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ContItemT.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Container.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ContainerP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ContainerT.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/CutPaste.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DesktopP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DialogS.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DialogSEP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DialogSP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DialogSavvyT.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Display.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DisplayP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DragC.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DragCP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DragDrop.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DragIcon.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DragIconP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DragOverS.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DragOverSP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DrawP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DrawingA.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DrawingAP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DrawnB.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DrawnBP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DropSMgr.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DropSMgrP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DropTrans.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/DropTransP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ExtObjectP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/FileSB.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/FileSBP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Form.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/FormP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Frame.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/FrameP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Gadget.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/GadgetP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/GrabShell.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/GrabShellP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/IconG.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/IconGP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/IconH.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/JoinSideT.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Label.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/LabelG.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/LabelGP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/LabelP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/LayoutT.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/List.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ListP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/MainW.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/MainWP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Manager.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ManagerP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/MenuShell.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/MenuShellP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/MenuT.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/MenuUtilP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/MessageB.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/MessageBP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/MwmUtil.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/NavigatorT.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Notebook.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/NotebookP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/PanedW.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/PanedWP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Primitive.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/PrimitiveP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Print.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/PrintSP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Protocols.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ProtocolsP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/PushB.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/PushBG.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/PushBGP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/PushBP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/RepType.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/RowColumn.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/RowColumnP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/SSpinB.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/SSpinBP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/SashP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Scale.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ScaleP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Screen.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ScreenP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ScrollBar.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ScrollBarP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ScrollFrameT.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ScrolledW.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ScrolledWP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/SelectioB.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/SelectioBP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/SeparatoG.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/SeparatoGP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Separator.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/SeparatorP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ShellEP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/SpecRenderT.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/SpinB.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/SpinBP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/TakesDefT.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/TearOffBP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/TearOffP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Text.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/TextF.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/TextFP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/TextFSelP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/TextInP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/TextOutP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/TextP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/TextSelP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/TextStrSoP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ToggleB.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ToggleBG.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ToggleBGP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/ToggleBP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/TraitP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Transfer.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/TransferP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/TransferT.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/TransltnsP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/TxtPropCv.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/VaSimpleP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/VendorS.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/VendorSEP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/VendorSP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/VirtKeys.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/VirtKeysP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/Xm.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/XmAll.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/XmIm.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/XmP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/XmStrDefs.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/XmosP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/Xm/XpmP.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/uil/Uil.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/uil/UilDBDef.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/uil/UilDef.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/uil/UilSymDef.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/uil/UilSymGl.h conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/include/uil/XmAppl.uil conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/lib64/libMrm.so conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/lib64/libUil.so conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/lib64/libXm.so conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/ApplicationShell.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/Composite.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/Constraint.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/Core.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/Object.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/OverrideShell.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/Shell.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/TopLevelShell.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/TransientShell.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/VendorShell.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmArrowButton.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmArrowButtonGadget.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmBulletinBoard.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmCascadeButton.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmCascadeButtonGadget.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmComboBox.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmCommand.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmDialogShell.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmDisplay.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmDragContext.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmDragIcon.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmDrawingArea.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmDrawnButton.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmDropTransfer.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmFileSelectionBox.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmForm.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmFrame.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmGadget.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmIconGadget.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmLabel.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmLabelGadget.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmList.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmMainWindow.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmManager.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmMenuShell.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmMessageBox.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmNotebook.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmPanedWindow.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmPrimitive.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmPushButton.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmPushButtonGadget.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmRowColumn.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmScale.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmScreen.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmScrollBar.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmScrolledWindow.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmSelectionBox.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmSeparator.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmSeparatorGadget.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmSpinBox.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmString.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmText.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmTextField.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmToggleButton.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
>   file /usr/share/man/man3/XmToggleButtonGadget.3.gz conflicts between attempted installs of lesstif-devel-0.95.2-9.fc23.x86_64 and motif-devel-2.3.4-10.fc23.x86_64
> 
> Résumé des erreurs
> -------------
> 
> root@blue-lagoon:~# 

Reagrds,
Laurent G
Comment 5 Thomas Woerner 2015-11-10 11:33:12 EST
Packages that require motif-devel in F-23:

motif-static
xbae-devel

Packages that require lesstif-devel in F-23:

InventorXt-devel
grass-devel
mesa-libGLw-devel

Do you have a mixture of these packages installed or something additional to the fedora repo?
Comment 6 Laurent G 2015-11-10 12:03:43 EST
Hi,

I'm still in F22 as the upgrade fails.

Here is the requested info:
> root@blue-lagoon:~# dnf list installed | grep "motif-static\|xbae-devel"
> root@blue-lagoon:~# dnf list installed | grep -i "InventorXt-devel\|grass-devel\|mesa-libGLw-devel"
> mesa-libGLw-devel.i686                 8.0.0-5.fc22              @fedora        

Actually I only have lesstif thing installed unril now:
> root@blue-lagoon:~# dnf list installed | grep -i "motif\|lesstif"
> lesstif.i686                           0.95.2-8.fc22             @fedora        
> lesstif.x86_64                         0.95.2-8.fc22             @fedora        
> lesstif-devel.x86_64                   0.95.2-8.fc22             @fedora
Comment 7 Michal Jaegermann 2015-11-28 16:33:03 EST
(In reply to Laurent G from comment #6)
> Hi,
> 
> I'm still in F22 as the upgrade fails.
> 
AFAICS an attempt to upgrade to F23 on a system where mesa-libGLw-devel was installed currently gets:
  Processing Dependency: motif-devel for package: mesa-libGLw-devel-8.0.0-7.fc23.x86_64
and if lesstif-devel.x86_64 was already present (quite likely as it shows up in a number of dependencies for other packages) then one gets a long list of conflicts, as in comment #4, and the whole upgrade fails.  Dropping beforehand mesa-libGLw-devel allows such upgrade to proceed.

I understand that lesstif is supposed to be replaced on a longer run by motif but apparently not enough care went into this operation to avoid breaking upgrades.
Comment 8 Amnon Harel 2016-02-16 03:58:11 EST
(In reply to Michal Jaegermann from comment #7)
> (In reply to Laurent G from comment #6)

To complement (and compliment) the useful information here, for those that like me find this thread while searching for solutions when their upgrade to Fedora 23 fails:

Found myself in the same situation as Laurent in #6, except that I had packages that depend on lesstif (cernlib, xbae, mesa-libGLw). So what worked for me was the flip-side of Michal's solution - I did a dnf remove lesstif and removed it together with all the packages that depend on it. I'll reinstall them to use motif as needed, later one.
Comment 9 Volker Fröhlich 2016-05-03 17:42:52 EDT
For reference: Grass 7 no longer uses this library.
Comment 10 Fedora End Of Life 2016-11-24 07:46:32 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 11 Fedora End Of Life 2016-12-20 09:58:40 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.