Bug 127119 - Kernel Oops "sleeping function called from invalid context at include/linux/rwsem.h"
Kernel Oops "sleeping function called from invalid context at include/linux/r...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-02 01:10 EDT by Thornton Prime
Modified: 2015-01-04 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 00:42:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thornton Prime 2004-07-02 01:10:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:

System paniced.

Debug: sleeping function called from invalid context at
include/linux/rwsem.h:43in_atomic():0, irqs_disabled():1
 [<02116834>] __might_sleep+0x80/0x8a
 [<0213fce7>] rw_vm+0x9b/0x218
 [<02137167>] do_no_page+0x59/0x24a
 [<0211579b>] try_to_wake_up+0x21/0x7f
 [<0211579b>] try_to_wake_up+0x21/0x7f
 [<02140096>] get_user_size+0x2e/0x55
 [<0211579b>] try_to_wake_up+0x21/0x7f
 [<0211430e>] __is_prefetch+0x1a7/0x295
 [<021362a4>] follow_page+0xd2/0xdd
 [<0211579b>] try_to_wake_up+0x21/0x7f
 [<0211579b>] try_to_wake_up+0x21/0x7f
 [<0211466a>] do_page_fault+0x26e/0x446
 [<0212e92d>] __rmqueue+0xa9/0x104
 [<0212ecb8>] buffered_rmqueue+0x124/0x147
 [<0212ef85>] __alloc_pages+0x2aa/0x2b4
 [<021143fc>] do_page_fault+0x0/0x446
 [<0211579b>] try_to_wake_up+0x21/0x7f
 [<02115e8c>] __wake_up_common+0x32/0x54
 [<02115ebf>] __wake_up+0x11/0x1a
 [<02234a17>] sock_def_readable+0x1f/0x42
 [<0227e462>] unix_dgram_sendmsg+0x384/0x405
 [<1287417d>] ext3_get_inode_loc+0x4f/0x1f7 [ext3]
 [<02115ebf>] __wake_up+0x11/0x1a
 [<0223225c>] sock_sendmsg+0x88/0xa2
 [<12874cd8>] ext3_dirty_inode+0x5b/0x5f [ext3]
 [<0215968c>] __mark_inode_dirty+0x28/0x14c
 [<0214b97e>] path_release+0xa/0x25
 [<0227d689>] unix_find_other+0x94/0xfb
 [<022332df>] sys_sendto+0xc7/0xe2
 [<022330f7>] sys_connect+0x6b/0x86
 [<02233104>] sys_connect+0x78/0x86
 [<0219256e>] vsprintf+0xd/0xf
 [<0215395e>] d_instantiate+0x3f/0x42
 [<02232024>] sock_map_file+0x98/0x106
 [<0213639b>] follow_page_pfn+0xec/0xfd
 [<02233313>] sys_send+0x19/0x1d
 [<022339bd>] sys_socketcall+0xd2/0x179
 [<0214f1bb>] sys_fcntl64+0x74/0x7b
                                                                     
          
Unable to handle kernel paging request at virtual address a0228650
 printing eip:
0211579b
*pde = 00000000
Oops: 0000 [#9]
Modules linked in: ipt_REJECT ipt_REDIRECT ipt_MASQUERADE iptable_nat
iptable_mdCPU:    0
EIP:    0060:[<0211579b>]    Not tainted
EFLAGS: 00010016   (2.6.6-1.435)
EIP is at try_to_wake_up+0x21/0x7f
eax: 02349920   ebx: 00000001   ecx: 00000000   edx: 0324ad4c
esi: a0228650   edi: 02349920   ebp: 0324ad5c   esp: 0324ad44
ds: 007b   es: 007b   ss: 0068
Process login (pid: 22443, threadinfo=0324a000 task=110b96d0)
Stack: 00000000 00000000 00000016 081db00c 00000001 1182b758 0324ad80
02115e8c
       00000000 00000000 1182b758 00000001 00000287 7fffffff 06236880
0324ad94
       02115ebf 00000000 00000000 10c265e0 10c265e0 02234a17 00000000
06236840
Call Trace:
 [<02115e8c>] __wake_up_common+0x32/0x54
 [<02115ebf>] __wake_up+0x11/0x1a
 [<02234a17>] sock_def_readable+0x1f/0x42
 [<0227e462>] unix_dgram_sendmsg+0x384/0x405
 [<1287417d>] ext3_get_inode_loc+0x4f/0x1f7 [ext3]
 [<02115ebf>] __wake_up+0x11/0x1a
 [<0223225c>] sock_sendmsg+0x88/0xa2
 [<12874cd8>] ext3_dirty_inode+0x5b/0x5f [ext3]
 [<0215968c>] __mark_inode_dirty+0x28/0x14c
 [<0214b97e>] path_release+0xa/0x25
 [<0227d689>] unix_find_other+0x94/0xfb
 [<022332df>] sys_sendto+0xc7/0xe2
 [<022330f7>] sys_connect+0x6b/0x86
 [<02233104>] sys_connect+0x78/0x86
 [<0219256e>] vsprintf+0xd/0xf
 [<0215395e>] d_instantiate+0x3f/0x42
 [<02232024>] sock_map_file+0x98/0x106
 [<0213639b>] follow_page_pfn+0xec/0xfd
 [<02233313>] sys_send+0x19/0x1d
 [<022339bd>] sys_socketcall+0xd2/0x179
 [<0214f1bb>] sys_fcntl64+0x74/0x7b
                                                                     
          
Code: 8b 06 85 c3 74 49 83 7e 28 00 75 3d 83 f8 02 75 0a ff 4f 10


Version-Release number of selected component (if applicable):
kernel-2.6.6-1.435

How reproducible:
Couldn't Reproduce


Additional info:

I'm not sure what caused the oops, but if you need I can whatever
tests you like on the system.
Comment 1 Dave Jones 2005-01-14 00:42:27 EST
this should be fixed in one of the several updates that followed this kernel.
if its still a problem, please reopen

Note You need to log in before you can comment on or make changes to this bug.