Bug 1271307 - Migration Guide: Ordering of Deployments section could be more clear
Migration Guide: Ordering of Deployments section could be more clear
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.4.0
Unspecified Unspecified
unspecified Severity unspecified
: post-GA
: One-off release
Assigned To: sgilda
Peer review completed
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-13 11:11 EDT by Phil Festoso
Modified: 2016-10-20 15:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 23091, Migration Guide-6.4 Build Date: 06-08-2015 08:58:14 Topic ID: 5946-765965 [Latest]
Last Closed: 2016-10-20 15:16:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Festoso 2015-10-13 11:11:00 EDT
Title: Review What's New and Different in JBoss EAP 6

Describe the issue:
The paragraph describing Ordering of Deployments in the Migration Guide is too narrow in its description of applications that may require config changes. According to the 6.4 Guide:

"JBoss EAP 5 applications that consist of multiple modules deployed as EARs and use legacy JNDI lookups instead of CDI injection or resource-ref entries"

Customer experience has shown that any deployed app (not just EARs) that uses legacy JNDI lookups runs the risk of dependency/timing issues.

Suggestions for improvement:

Change to be more inclusive and alert the customer that a review of their app  may be necessary.

"applications that consist of multiple modules deployed as EARs OR THAT use legacy JNDI lookups"

Additional information:
Submitted on customer behalf.
Comment 5 sgilda 2016-01-27 07:08:28 EST
David,

I modified topic 5946 to remove "deployed as EARs" from the following section:

Ordering of deployments

    JBoss EAP 6 uses fast, concurrent initialization for deployment resulting in improved performance and efficiency. In most cases, the application server is able to automatically determine dependencies in advance and choose the most efficient deployment strategy. However, JBoss EAP 5 applications that consist of multiple modules deployed as EARs and use legacy JNDI lookups instead of CDI injection or resource-ref entries may require configuration changes.

The resulting text now says:

Ordering of deployments

    JBoss EAP 6 uses fast, concurrent initialization for deployment resulting in improved performance and efficiency. In most cases, the application server is able to automatically determine dependencies in advance and choose the most efficient deployment strategy. However, JBoss EAP 5 applications that consist of multiple modules and use legacy JNDI lookups instead of CDI injection or resource-ref entries may require configuration changes.

This change seems to be targeted to migration because it talks about how deployments configured for JBoss EAP 5 that contain multiple modules and use JNDI might need to be changed when you move to JBoss EAP 6. 

Also, this change will take effect in the 6.4 Migration Guide the next time it is built for the Customer Portal.

David, I'm sorry if I misunderstood what you are asking me. Let me know if this doesn't answer your question.
Comment 6 sgilda 2016-01-27 07:10:58 EST
David, to clarify, I don't understand how this change would releate to the 6.4 Development Guide in CS 23088.
Comment 10 sgilda 2016-09-15 13:04:47 EDT
Moving back to MODIFIED as this was updated.
Comment 11 sgilda 2016-09-15 13:20:38 EDT
Moving back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.