Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1271340 - engine can't log in to satellite
Summary: engine can't log in to satellite
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ovirt-3.6.0-ga
: 3.6.0
Assignee: Oved Ourfali
QA Contact: movciari
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-13 17:05 UTC by movciari
Modified: 2016-02-10 19:14 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-27 07:57:30 UTC
oVirt Team: Infra
rule-engine: ovirt-3.6.0+
rule-engine: blocker+
ylavi: planning_ack+
masayag: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 47319 0 master MERGED engine: Use UUID as content host id on Satellite Never
oVirt gerrit 47350 0 ovirt-engine-3.6 MERGED engine: Use UUID as content host id on Satellite Never
oVirt gerrit 47352 0 ovirt-engine-3.6.0 MERGED engine: Use UUID as content host id on Satellite Never

Description movciari 2015-10-13 17:05:27 UTC
Description of problem:
I added Satellite 6 as an external provider, checked that credentials are valid, hitting test button in new/edit external provider says it succeeded, and my engine host is added as content host in Satellite.
When I click Errata link in webadmin's tree view, I get an error "Problem retrieving errata: PROVIDER_FAILURE"

Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.18.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Add Satellite as an external provider, use http protocol and authentication, test it to be sure
2. Add engine host as content host in this Satellite instance
3. Hit "Errata" link in webadmin's tree view

Actual results:
returns an error

Expected results:
should show available errata

Additional info:

Comment 3 Oved Ourfali 2015-10-14 05:56:30 UTC
It seems like the satellite user doesn't have any default organization defined.
Moti - please help Michal set it up.

Comment 4 Pavel Stehlik 2015-10-14 07:42:52 UTC
Michal, does the log says hint why it fails?

Comment 5 movciari 2015-10-14 07:58:10 UTC
I assigned that user a default organization and location, I'm posting new log.
The new log says error 400

Comment 8 Moti Asayag 2015-10-14 10:49:02 UTC
The root cause of the bug is a difference in the semantic of the ID field under the /katello/api/v2/systems/:id resource between Katello to Satellite.

The :id field in Katello represents the UUID of the content host, however under satellite it is a sequence number.

Only with the value of the UUID the content host can be identified in candlepin.

The solution will be to use the UUID field of the system resource instead of the ID.

Comment 9 Sandro Bonazzola 2015-11-27 07:57:30 UTC
Since oVirt 3.6.0 has been released, moving from verified to closed current release.


Note You need to log in before you can comment on or make changes to this bug.