Bug 1271396 - segfault in kwin when using "Plastik" decoration
segfault in kwin when using "Plastik" decoration
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: kwin (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Vrátil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-13 16:51 EDT by Gerd v. Egidy
Modified: 2016-07-19 14:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 14:12:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace of kwin_x11 after the segfault (6.10 KB, text/plain)
2015-10-13 16:53 EDT, Gerd v. Egidy
no flags Details

  None (edit)
Description Gerd v. Egidy 2015-10-13 16:51:46 EDT
Description of problem:

I'm in the process of testing a migration of several workstations from Fedora 20 to 22, all using KDE. On one test workstation I get lot's of segfaults from kwin.

Version-Release number of selected component (if applicable):

kwin-5.4.1-1.fc22.x86_64

How reproducible: Always

Steps to Reproduce:
1. open a new kate process
2. Menu File, Open...

Actual results:
kwin segfaults before the open dialog is shown

Expected results:
open dialog shown, no segfault.

Additional info:

Using kate has proven to be the most reliable way to trigger it. But it happens with many other programs too, e.g. Firefox, Konqueror,... It usually happens when a new window or dialog should be shown.

I first thought this had something to do with desktop effects and the graphics driver, so I reduced the effects as much as I could. I also tried a Nvidia graphics card with Nouveau and an Intel one. Both did not fix or reduce the segfaults.

The user experiencing this had KDE 4 configured. Upgrading was done with fedup.
Comment 1 Gerd v. Egidy 2015-10-13 16:53 EDT
Created attachment 1082620 [details]
backtrace of kwin_x11 after the segfault
Comment 2 Rex Dieter 2015-10-13 17:11:09 EDT
Seems to be related to kwin decoration, what decoration are you using?
Comment 3 Gerd v. Egidy 2015-10-13 17:33:23 EDT
Thanks for your quick reply.

I'm using the "Plastik" decoration.

When I switch to "org.kde.breeze", log out, log in again I can't reproduce the problem anymore (at least not so quick, haven't tried for a longer time yet). Switching back to Plastik, log out, log in and the segfaults are back.

So the problem seems indeed to be related to the windows decoration.
Comment 4 Fedora End Of Life 2016-07-19 14:12:53 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.