Bug 1271495 - When try mem slots more than 256 and specify the maxcpus=240, qemu will print warning.
When try mem slots more than 256 and specify the maxcpus=240, qemu will prin...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Igor Mammedov
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 03:24 EDT by Qian Guo
Modified: 2016-03-28 05:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-14 11:08:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qian Guo 2015-10-14 03:24:13 EDT
Description of problem:
In fact, if the mem slots are set more than 206, then set the maxcpus=240, the qemu will prompts:
qemu-kvm: Warning: ACPI tables are larger than 64k.
qemu-kvm: Warning: migration may not work.
qemu-kvm: Warning: please remove CPUs, NUMA nodes, memory slots or PCI bridges.
qemu-kvm: Warning: ACPI tables are larger than 64k.
qemu-kvm: Warning: migration may not work.
qemu-kvm: Warning: please remove CPUs, NUMA nodes, memory slots or PCI bridges.


But the cpus is not actually equals 240(just set smp=1), so qemu should not tell that the table is out of range. If need, it should refuse to boot when the actual vcpus are larger than 240, or refuse to hotplug the cpu numbers that may break the range.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
situation 1:
1.Boot with mem slots over 206 and smp=1 and set maxcpus=240
# /usr/libexec/qemu-kvm -smp 1,cores=1,sockets=1,threads=1,maxcpus=240     -m 16G,slots=256,maxmem=40G 

situation 2:
1. Boot with mem slots 256 and smp 240.

# /usr/libexec/qemu-kvm -smp 240     -m 16G,slots=256,maxmem=40G VNC server running on `::1:5900'
qemu-kvm: Warning: ACPI tables are larger than 64k.
qemu-kvm: Warning: migration may not work.
qemu-kvm: Warning: please remove CPUs, NUMA nodes, memory slots or PCI bridges.
qemu-kvm: Warning: ACPI tables are larger than 64k.
qemu-kvm: Warning: migration may not work.
qemu-kvm: Warning: please remove CPUs, NUMA nodes, memory slots or PCI bridges.



Actual results:
For Both situation:
the qemu prompts as followings, but not quit.

qemu-kvm: Warning: ACPI tables are larger than 64k.
qemu-kvm: Warning: migration may not work.
qemu-kvm: Warning: please remove CPUs, NUMA nodes, memory slots or PCI bridges.
qemu-kvm: Warning: ACPI tables are larger than 64k.
qemu-kvm: Warning: migration may not work.
qemu-kvm: Warning: please remove CPUs, NUMA nodes, memory slots or PCI bridges.


2.

Expected results:
For situation 1, should not prompts, due to it does not break the range.

For situation 2, should not boot up, qemu should refuse to boot up due to the acpi tables are larger than 64k.

Additional info:
Comment 2 Igor Mammedov 2015-10-14 11:08:38 EDT
ACPI table size depends on 'possible' number of CPUs or memory slots, which is what 'maxcpus' and 'slots' and these possible devices must be present in
ACPI tables for hotplug to be operational.

Warnings warn user that migration 'may" not work, and that only true for backwards migration to a QEMU in releases earlier than 7.2.

Warnings are introduced intentionally to warn about possible broken migration
instead of silently trying to run with the broken configuration as it is in 7.1 and earlier releases.

Note You need to log in before you can comment on or make changes to this bug.