Bug 1271586 - Package Upload to Products via GUI is not updating Info - regression
Package Upload to Products via GUI is not updating Info - regression
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Eric Helms
Og Maciel
http://projects.theforeman.org/issues...
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 07:09 EDT by Roman Plevka
Modified: 2016-07-27 07:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:22:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 10327 None None None Never

  None (edit)
Description Roman Plevka 2015-10-14 07:09:46 EDT
Description of problem:
After uploading a package to the yum repo using WebGUI, the repository is not being refreshed and the package is not visible.
The package is being uploaded and added to the pulp directory tree correctly.
Same action works correctly with using Hammer CLI.
(hammer repository upload-content --product my_product_1 --organization-id 1 --name test_1_good --path mypackage.9.603.5-1.x86_64.rpm )

Version-Release number of selected component (if applicable):
# rpm -qa katello
katello-2.4.0-6.nightly.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. using WebUI, create a product
2. create a yum repository within this product
3. upload a package using the 'upload package' form


Actual results:
The info about packages and errata is not being refreshed,
the package is unable to be found.

Expected results:
The uploaded packages are properly indexed and shown


Additional info:
Workaround: 
you can have the repo 'refreshed' by 'syncing' it.
Even if it is a custom local repo, you can put some text into "url" field, which enables the "Sync Now" button.
The sync runs and fails (of course), but the task performs some kind of refresh.
The packages will be now shown.
Comment 3 Bryan Kearney 2016-01-12 14:03:36 EST
Upstream bug assigned to ehelms@redhat.com
Comment 4 Bryan Kearney 2016-01-12 14:03:38 EST
Upstream bug component is Content Management
Comment 5 Bryan Kearney 2016-01-12 14:03:41 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/10327 has been closed
Comment 6 Bryan Kearney 2016-02-05 10:41:43 EST
Upstream bug component is Content Management
Comment 7 Bryan Kearney 2016-02-05 10:44:07 EST
No idea why I moved this to FailedQA.
Comment 8 Bryan Kearney 2016-02-05 12:06:43 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/10327 has been closed
Comment 11 Bryan Kearney 2016-03-31 14:18:01 EDT
Upstream bug assigned to ehelms@redhat.com
Comment 12 Bryan Kearney 2016-04-01 02:07:56 EDT
Upstream bug assigned to ehelms@redhat.com
Comment 13 Mike McCune 2016-04-01 18:11:06 EDT
This worked fine for me on 6.2 SNAP 6, moving ON_QA

you can see a recording I did of the upload here:

https://mmccune.fedorapeople.org/scratch/upload-package.gif
Comment 14 Og Maciel 2016-04-04 14:13:11 EDT
I have also been able to test this issue (see comment #13) and will mark it as VERIFIED on Satellite 6.2.0 SNAP 6.1
Comment 15 Bryan Kearney 2016-07-27 07:22:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.