Bug 1271634 - kig freezes upon "save as"
kig freezes upon "save as"
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kig (Show other bugs)
22
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 08:20 EDT by Maurizio Paolini
Modified: 2016-02-24 10:05 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-24 10:05:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 353897 None None None 2016-02-24 10:05 EST

  None (edit)
Description Maurizio Paolini 2015-10-14 08:20:41 EDT
[This is a really annoying problem; however I was uncertain whether to file
a bug report since I am not able to give a procedure to always reproduce it]


Description of problem:

After building a (complicated) kig construction, pressing the "Save as"
button to save the construction to file sometimes completely freezes kig
and the only way out is to kill the process from the shell (thus losing all
the work)


Version-Release number of selected component (if applicable):

kig-15.04.3-1.fc22.i686


How reproducible:

This is sporadic and happened to me twice, after starting kig without arguments and making a lengthy kig construction.
Unfortunately I am not able to give a procedure to reproduce the problem.

Steps to Reproduce:
As mentioned above, the problem is not deterministic, however when it
happens it causes the loss of all work.
My hope is that someone having the same problem could confirm it and add more information.


Additional info:

I also tried a fresh installation from source, in which case I did not see the
problem.  It *might* be that the problem goes away after migration to the more
recent "Applications/15.08" release.
Comment 1 Maurizio Paolini 2015-10-14 09:29:06 EDT
I just experienced a "freeze" on "Save as" with a fresh installation from the
latest sources of kig (git master).  I will then file a bug report upstream.
Comment 2 Rex Dieter 2016-02-24 10:05:15 EST
tracking upstream...

Note You need to log in before you can comment on or make changes to this bug.