Bug 1271701 - awk matches lowercase when searching for uppercase range
awk matches lowercase when searching for uppercase range
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gawk (Show other bugs)
6.6
All Linux
urgent Severity high
: rc
: ---
Assigned To: David Kaspar [Dee'Kej]
Filip Holec
: Patch, Reproducer, ZStream
Depends On: 1250830
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 09:59 EDT by Jan Kurik
Modified: 2016-04-18 06:27 EDT (History)
12 users (show)

See Also:
Fixed In Version: gawk-3.1.7-10.el6_7.1
Doc Type: Bug Fix
Doc Text:
Cause: In previous versions, the 'gawk' utility was using the POSIX definition as default, when searching for a range patterns of given regular expression. For example, if you used regular expression '[A-Z]', it also matched lowercase symbols of alphabet. Consequence: This behaviour was not intuitive and was confusing to many users of 'gawk' Fix: Upstream of the 'gawk' has already introduced patches to change it to the more intuitive behaviour. We have backported all the related changed to the current version of the 'gawk' utility. Result: After the fix, the 'gawk' utility's regular expressions match only uppercase characters when '[A-Z]' is used. However, the previous behaviour can be still enabled if needed, by using the '--posix' parameter of the 'gawk'.
Story Points: ---
Clone Of: 1250830
Environment:
Last Closed: 2015-11-10 04:14:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-10-14 09:59:36 EDT
This bug has been copied from bug #1250830 and has been proposed
to be backported to 6.7 z-stream (EUS).
Comment 9 errata-xmlrpc 2015-11-10 04:14:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2003.html

Note You need to log in before you can comment on or make changes to this bug.