Bug 1271721 - [Cinder] Cinder disk with ceph backend actual size is not '0'
[Cinder] Cinder disk with ceph backend actual size is not '0'
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity low (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Daniel Erez
Ori Gofen
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 10:31 EDT by Ori Gofen
Modified: 2016-05-25 21:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:18:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: ovirt‑3.6.z?
ogofen: planning_ack?
tnisan: devel_ack+
ogofen: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47458 master MERGED core,restapi: DiskMapper - invalidate ActualSize for Cinder disks Never
oVirt gerrit 47512 ovirt-engine-3.6 MERGED core,restapi: DiskMapper - invalidate ActualSize for Cinder disks Never

  None (edit)
Description Ori Gofen 2015-10-14 10:31:32 EDT
Description of problem:
from py-sdk ->

>>> cinder_disk = ovirtremote.api.disks.get('vm_cinder_2_Disk_1')
>>> cinder_disk.get_actual_size()
0

cinder storage component does not give any information regarding the total allocated space of a volume created with ceph backend.
oVirt now return a wrong and misleading size '0'
Version-Release number of selected component (if applicable):
rhevm-3.6-14

How reproducible:
100%

Steps to Reproduce:
1.get disk actual_size

Actual results:
wrong size

Expected results:
should be either '-1' or 'None/null' or something else that does not represents a valid answer to this query.

Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 06:50:10 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Yaniv Lavi (Dary) 2015-10-29 08:43:43 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 3 Ori Gofen 2015-12-16 02:37:38 EST
Verified on rhevm-3.6.1.3-0.1.el6.noarch.
size section shows 'NONE'
Comment 4 Sandro Bonazzola 2015-12-16 07:18:52 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.