Bug 1271764 - Overcloud deployment failing with OsNetConfigImpl.properties.config: Items to join must be strings 23
Overcloud deployment failing with OsNetConfigImpl.properties.config: Items to...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity urgent
: ---
: 7.0 (Kilo)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 11:55 EDT by Eduard Barrera
Modified: 2016-04-18 03:01 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-20 13:51:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduard Barrera 2015-10-14 11:55:02 EDT
Description of problem:

We are getting the following error when deploying the overcloud:

[stack@qviebvmtst01 ~]$ date;time openstack overcloud deploy --templates ~/templates/my-overcloud -e ~/templates/my-overcloud/environments/network-isolation.yaml -e ~/templates/network-environment.yaml --control-flavor control --compute-flavor compute --ntp-server 10.60.64.6 --neutron-network-type vxlan --neutron-tunnel-types vxlan;date
...
...
Tue Oct 13 16:03:37 GMT 2015
Deploying templates in the directory /home/stack/templates/my-overcloud
Stack failed with status: Resource CREATE failed: resources.NetworkConfig: resources.Compute.resources[0].Property error: resources.OsNetConfigImpl.properties.config: Items to join must be strings 23
ERROR: openstack Heat Stack create failed.

This number 23 is related to the netmask on network-environment.yaml, we tested it with 23 and 24 and the number on the error changed

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. use the attached  network-environment.yaml,
2. openstack overcloud deploy --templates ~/templates/my-overcloud -e ~/templates/my-overcloud/environments/network-isolation.yaml -e ~/templates/network-environment.yaml --control-flavor control --compute-flavor compute --ntp-server 10.60.64.6 --neutron-network-type vxlan --neutron-tunnel-types vxlan


Actual results:
Stack failed with status: Resource CREATE failed: resources.NetworkConfig: resources.Compute.resources[0].Property error: resources.OsNetConfigImpl.properties.config: Items to join must be strings 23
ERROR: openstack Heat Stack create failed.


Expected results:
Deployment finished without errors


Additional info:
Comment 5 chris alfonso 2015-10-19 12:26:39 EDT
Would you mind updating this bug with the current status. I'm not sure what's actionable on this now, I think the issue is resolved. Please confirm.
Comment 6 Sebastien Aime 2015-10-19 12:31:54 EDT
Hello,

We have planned with the customer to update their templates tomorrow before issuing a new deployment. I believe that we're on a good track now, I will let you know. I'll leave the NEEDINFO flag for now.

Regards,

Sebastien.
Comment 8 Mike Burns 2015-10-20 13:51:18 EDT
Since there are separate efforts around documentation, closing this as notabug

Note You need to log in before you can comment on or make changes to this bug.