Bug 1271897 - Can't use 'defined(@array)' (Maybe you should just omit the defined()?) at /usr/bin/cloc line 1178.
Can't use 'defined(@array)' (Maybe you should just omit the defined()?) at /u...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cloc (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 22:30 EDT by Guillaume Poirier-Morency
Modified: 2015-11-25 08:34 EST (History)
3 users (show)

See Also:
Fixed In Version: cloc-1.64-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-25 08:34:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guillaume Poirier-Morency 2015-10-14 22:30:44 EDT
Description of problem:

The script is broken, probably due to a Perl update.

Version-Release number of selected component (if applicable):

1.62 release 1

How reproducible:

Simply call cloc

Actual results:

Can't use 'defined(@array)' (Maybe you should just omit the defined()?) at /usr/bin/cloc line 1178.
Comment 1 Robert Kuska 2015-11-12 09:15:36 EST
I hit the same problem.
Comment 2 Fedora Update System 2015-11-12 10:23:26 EST
cloc-1.64-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ace1344e02
Comment 3 Fedora Update System 2015-11-13 00:29:24 EST
cloc-1.64-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update cloc'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ace1344e02
Comment 4 Fedora Update System 2015-11-23 15:56:55 EST
cloc-1.64-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.