This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 127195 - nforce2 (shuttle sn41g2) ethernet doesnt work on latest kernels
nforce2 (shuttle sn41g2) ethernet doesnt work on latest kernels
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-03 14:45 EDT by Ed Price
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.7-1.494.2.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-03 19:00:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg for working kernel (10.30 KB, text/plain)
2004-07-03 14:47 EDT, Ed Price
no flags Details
dmesg for non-working kernel (10.53 KB, text/plain)
2004-07-03 14:47 EDT, Ed Price
no flags Details
lspci, /proc/interrupts, and dmesg for working kernel (22.38 KB, text/plain)
2004-07-11 10:14 EDT, Brian Schousek
no flags Details
lspci, /proc/interrupts, and dmesg for non-working kernel (22.86 KB, text/plain)
2004-07-11 10:14 EDT, Brian Schousek
no flags Details
dmesg for linux-2.6.8-rc1 (works) (11.24 KB, text/plain)
2004-07-13 11:53 EDT, Ed Price
no flags Details
dmesg for kernel-2.6.7-1.478 (works) (14.30 KB, text/plain)
2004-07-13 11:53 EDT, Ed Price
no flags Details

  None (edit)
Description Ed Price 2004-07-03 14:45:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
eth0 works on kernel-2.6.5-1.358, but not on kernel-2.6.6-1.435 or
kernel-2.6.6-1.435.2.3, on fresh install of FC2 on Shuttle SN41G2
(nvidia nforce2).


Version-Release number of selected component (if applicable):
kernel-2.6.6-1.435.2.3

How reproducible:
Always

Steps to Reproduce:
1. reboot into kernel-2.6.6-1.435 or 2.6.6-1.435.2.3
2. 
3. 



Actual Results:  initialization of eth0 fails.

Expected Results:  working eth0.


Additional info:

i tried adding "acpi=off" (in grub.conf) but it did not solve the problem.

lspci:

00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different
version?) (rev a2)
00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1
(rev a2)
00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4
(rev a2)
00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3
(rev a2)
00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2
(rev a2)
00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5
(rev a2)
00:01.0 ISA bridge: nVidia Corporation nForce2 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a3)
00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a3)
00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet
Controller (rev a1)
00:05.0 Multimedia audio controller: nVidia Corporation nForce
MultiMedia audio [Via VT82C686B] (rev a2)
00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97
Audio Controler (MCP) (rev a1)
00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI Bridge
(rev a3)
00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2)
00:0d.0 FireWire (IEEE 1394): nVidia Corporation nForce2 FireWire
(IEEE 1394) Controller (rev a3)
00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev a2)
02:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4
MX - nForce GPU] (rev a3)
Comment 1 Ed Price 2004-07-03 14:47:11 EDT
Created attachment 101614 [details]
dmesg for working kernel
Comment 2 Ed Price 2004-07-03 14:47:40 EDT
Created attachment 101615 [details]
dmesg for non-working kernel
Comment 3 Ed Price 2004-07-07 08:44:55 EDT
vanilla kernel.org linux-2.6.7 does not work either.
also tried 2.6.7-bk19 and that fails too.

WORKAROUND: disable USB 2.0 in BIOS (set "on-chip USB" to "1.1"
instead of "1.1+2.0").  after this eth0 works in kernel-2.6.6-1.435.2.3.
Comment 4 Brian Schousek 2004-07-11 10:13:09 EDT
I have the same problem with a Shuttle MN31N and onboard ethernet.
kernel 2.6.5-1.358 works fine but none of the 2.6.6 kernels (through
the now current 2.6.6-1.435.2.3) work. I'm attaching two files with
concatenated outputs from "/sbin/lspci -vxx", "cat /proc/interrupts",
and "dmesg" for working and non-working kernels.
Comment 5 Brian Schousek 2004-07-11 10:14:06 EDT
Created attachment 101791 [details]
lspci, /proc/interrupts, and dmesg for working kernel
Comment 6 Brian Schousek 2004-07-11 10:14:39 EDT
Created attachment 101792 [details]
lspci, /proc/interrupts, and dmesg for non-working kernel
Comment 7 Brian Schousek 2004-07-11 10:36:38 EDT
There seems to be some similar bug tracking activity on the kernel
bugzilla, but there kernel 2.6.6 works fine and it is 2.6.7 release
candidates that are causing problems.

http://bugzilla.kernel.org/show_bug.cgi?id=2920
http://bugzilla.kernel.org/show_bug.cgi?id=2846
http://bugzilla.kernel.org/show_bug.cgi?id=2799
Comment 8 Brian Schousek 2004-07-11 11:28:29 EDT
There's even a thread going on in linux.kernel complex enough to
include Linus Torvalds in its contributors regarding the 2.6.6->2.6.7
nforce issue. It looks like this is a pretty subtle bug involving
interrupt sharing. Link to the thread attached below:


http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&c2coff=1&threadm=23T5k-2MZ-5%40gated-at.bofh.it&rnum=4&prev=/groups%3Fq%3Dnforce%2B%2B2.6.6%2Bethernet%26hl%3Den%26lr%3D%26ie%3DUTF-8%26c2coff%3D1%26selm%3D23T5k-2MZ-5%2540gated-at.bofh.it%26rnum%3D4
Comment 9 Ed Price 2004-07-13 11:51:51 EDT
kernel.org linux-2.6.8-rc1 works.

fedora "development" (FC3-test1 i guess) kernel-2.6.7-1.478 works. 
(there was some strange hex in the boot messages though.)

Comment 10 Ed Price 2004-07-13 11:53:16 EDT
Created attachment 101864 [details]
dmesg for linux-2.6.8-rc1 (works)
Comment 11 Ed Price 2004-07-13 11:53:54 EDT
Created attachment 101865 [details]
dmesg for kernel-2.6.7-1.478 (works)
Comment 12 Barry K. Nathan 2004-07-14 05:38:21 EDT
2.6.7-1.478 has a patch for GPG signing of kernel modules. I think
that's where the hex output is coming from.
Comment 13 Michael Kotson 2004-07-24 02:24:21 EDT
I have the same issue with the 2.6.6-1.435.2.3 kernel on a Biostar 
M7NCG400 Nforce2 MB.  The change from USB 2.0 to USB 1.1 in BIOS 
worked for me as well.
Comment 14 Ed Price 2004-08-03 19:00:02 EDT
latest FC2 kernel (2.6.7-1.494.2.2) resolves this issue for me.

thx.  closing.
Comment 15 Brian Schousek 2004-08-06 00:48:00 EDT
Works for me too (2.6.7-1.494.2.2) FYI: Self-compiled 2.6.7 vanilla
kernel worked too, as dida 2.6.7-1.492 kernel from arjan.
Comment 16 Ed Price 2004-08-08 21:52:37 EDT
hmm, vanilla 2.6.7 worked?  maybe i should try that again, just to
double-check.

actually, FYI ..... at some point, it seemed that i could not
reproduce the original problem.  ie, even with USB 2.0 enabled i could
boot from previously non-working kernels, and eth0 worked!  i looked
at my history of up2date activity, thought maybe there was some other
component involved...  never figured it out.  just recently i
reinstalled FC2 from scratch, verified the original bug, then up2dated
things, except kernel, gradually, checking every time, but eth0 never
worked until i finally upgraded to kernel 2.6.7-1.494.2.2.  so i'm
still confused as to what happened on my previous install...

PS realized later that i probably should have closed with resolution
of "ERRATA" instead of "CURRENTRELEASE".  oops sorry.

Note You need to log in before you can comment on or make changes to this bug.