Bug 1271975 - sosreport collects "journalctl --list-boots" but the option is not available
sosreport collects "journalctl --list-boots" but the option is not available
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sos (Show other bugs)
7.2
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Pavel Moravec
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 04:17 EDT by masanari iida
Modified: 2015-10-15 06:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 06:13:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description masanari iida 2015-10-15 04:17:20 EDT
Description of problem:
sosreport collects journalctl --list-boots,
but the result in sos_commands/systemd/journalctl_--list-boots
always "journalctl: unrecognized option '--list-boots'"

Version-Release number of selected component (if applicable):
sos-3.2-15.el7_1.8.noarch
systemd-208-20.el7_1.6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run sosreport
2. Extraxt xz file
3. See sos_commands/systemd/journalctl_--list-boots

Actual results:
journalctl: unrecognized option '--list-boots'

Expected results:
Boot time and date should be display.

Additional info:
It seemed journalctl in systemd-208-20.el7_1.6 doesn't have this option.
Either remove this command from sos, or backport this option into 
systemd-208-20.el7 is a solution.

Business impact : none
Comment 2 Bryn M. Reeves 2015-10-15 06:13:16 EDT
This is not a bug in sos: we support multiple distributions from the same sos version meaning that there is some variation in the environment and tool capabilities where sos runs.

The same command on a recent Fedora system would produce something like:

$ cat sos_commands/systemd/journalctl_--list-boots
-3 cd6f638cafa4451bbff8f71f8e018388 Tue 2015-10-06 21:16:56 BST—Tue 2015-10-06 22:09:40 BST
-2 37aa3ac637d2499c9911566a14deb976 Tue 2015-10-06 22:09:50 BST—Wed 2015-10-07 10:15:56 BST
-1 c15e6ac9f12944069e6ace081d31201d Wed 2015-10-07 10:45:48 BST—Fri 2015-10-09 18:07:36 BST
 0 9180c1bf81f3466f93b9e656750098c6 Fri 2015-10-09 18:08:19 BST—Thu 2015-10-15 11:03:59 BST

> It seemed journalctl in systemd-208-20.el7_1.6 doesn't have this option.
> Either remove this command from sos, or backport this option into 
> systemd-208-20.el7 is a solution.

I believe persistent journald logs are disabled by policy in RHEL7 and that this is a requirement for any operation working with boot IDs, e.g.:

# journalctl -k -b -1
Failed to look up boot -1: Cannot assign requested address

Note that other products such as Atomic do use the journal (and this version of sos): if there is to be a change here it needs to be in the systemd packaging.

Note You need to log in before you can comment on or make changes to this bug.