Bug 1271984 - "500 Internal Server Error" or "undefined method 'state' for..." when listing VMs in RHEV compute resource
"500 Internal Server Error" or "undefined method 'state' for..." when listing...
Status: CLOSED DEFERRED
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources - RHEV (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 04:38 EDT by Antonin Pagac
Modified: 2017-03-13 16:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-13 16:14:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin Pagac 2015-10-15 04:38:23 EDT
Description of problem:
When trying to list VMs on freshly added RHEV compute resource, one of following errors appear:

"There was an error listing VMs: 500 Internal Server Error"
or
"There was an error listing VMs: undefined method `state' for #<Fog::Compute::Ovirt::Server:0x0000000a5c7ab0>"

There is no additional info in production.log

Version-Release number of selected component (if applicable):
Satellite Version 6.1.3 COMPOSE 6
Red Hat Enterprise Virtualization Manager Version: 3.6.0-0.18.el6

How reproducible:
There always appears an error, it seems to be random of the two errors mentioned.

Steps to Reproduce:
1. Add a rhev (3.6) compute resource
2. Click on Virtual Machines tab
3. One of the errors appears

Actual results:
Can't list VMs, error appears

Expected results:
Can list VMs, list of VMs appears

Additional info:
Sat6 running with updated fog:

ruby193-rubygem-fog-core-1.32.0-1.el7.noarch
ruby193-rubygem-fog-google-0.0.7-1.el7.noarch
ruby193-rubygem-fog-1.32.0-1.el7.noarch
ruby193-rubygem-fog-aws-0.7.2-1.el7.noarch
ruby193-rubygem-fog-json-1.0.0-2.1.el7.noarch
ruby193-rubygem-fog-xml-0.1.2-1.el7.noarch

Also updated is rbovirt:
ruby193-rubygem-rbovirt-0.0.35-1.el7.noarch
Comment 1 Antonin Pagac 2015-10-15 04:55:37 EDT
Tried also with rhevm3.5, the error appears there too.

Red Hat Enterprise Virtualization Manager Version: 3.5.0-0.32.el6ev
Comment 3 Bryan Kearney 2016-07-26 11:25:24 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 4 Bryan Kearney 2016-07-26 11:39:52 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 6 Bryan Kearney 2017-03-13 16:14:59 EDT
I do not see this bug being addressed in the near term. If you believe closing this is an issue, please feel free to re-open with additional information.

Note You need to log in before you can comment on or make changes to this bug.